Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using latest Arch Linux. But whenever I start my PC, it sometimes gets an IP address but most of the time, it gives me stress. I am getting very confused, how can I make sure it is really setting DHCP IP?

This is what I have:

In rc.conf:

DAEMONS=( ... network dhcpcd )

On system boot I have in ~/.xinitrc

ip link set dev eth0 up
ip link set dev eht1 up
dhcpcd -t 100

But now, I have rebooted 10 times, and I do not get any IP address.

Follow up:

Yesterday i had interfaces eth0, eth1, lo. After this strange problem of IP. Now i am successfully boot back to my same BOX, same configurations.

  1. I do not have any eth1 anymore
  2. Network cable was connected to eth1 (eth0 was not used because its in very messy place where i have lot of USB connected + Display cables connected)

Why my eth1 completely disappeared? (i never saw this in CentOS, Fedora in my 1 years linux driving experience)

share|improve this question
    
Why are you trying to bring two NIC's up (eth0 and eth1)? –  jasonwryan Oct 19 '11 at 7:16
    
@jasonwryan: because, if i connect internet cable, to eth0 or eht1, it take wrong interface such as eth0 connected but was before showing eth1. To be sure at-least i am on the network i used that (And it was working yesterday). I have my GRUB timeout=0, and i cant login anymore because i have a full screen slide shows). How do i go back to my grub menu for single boot login? So that i can share you the rc.conf. –  YumYumYum Oct 19 '11 at 7:29
    
You can only bring one NIC up - the primary one. Follow sr_'s advice and go through the page on the wiki and follow it exactly. Your login issue is a separate one. I don't understand why a slideshow prevents you acessing your console Ctrl-Alt-F{1-6}... –  jasonwryan Oct 19 '11 at 7:48
1  
After BIOS i pressed Ctrl+Alt+F{1 till 6} But i do not get GRUB menu. (i have GRUB timeout=0 and autologin and full screen slideshow after autologin, as a result i do not get anymore my terminal either). –  YumYumYum Oct 19 '11 at 7:52
    
(I misclicked ^ when I wanted to add a comment) @jasonwryan meant Ctrl+Alt+F1 after the system booted (into whatever you mean by slideshow), to access a plain text console. –  sr_ Oct 19 '11 at 8:09
show 1 more comment

1 Answer 1

up vote 1 down vote accepted

Some notes on your question, maybe it helps, hopefully:

  1. ~/.xinitrc is not the right place for these settings, see for example here, in the "ArchWiki"

  2. Don't fight your distribution, ArchLinux's system startup is configured via /etc/rc.conf, which is pretty neat. This includes the network configuration, see again the ArchWiki for details, especially the part on DHCP IP. Try to setup networking in the way it is described there and if this fails, it'd be good to have more information on the failure (logs, details about how it was configured). As you can see, the ArchWiki is a valuable resource :)

By the way, the eht1 is just a typo, right?

Oh, another reason for using the distribution-specific way to configure networking, you can simply use /etc/rc.d/network restart to reconfigure (as root), so there should be no need to reboot.

share|improve this answer
    
You could use a live-cd (or live-system on a bootable USB drive, maybe even your install medium's rescue system) to access grub's config file, edit the timeout value, go on from there. –  sr_ Oct 19 '11 at 7:55
    
please see my follow up section. Why i do not have anymore eth1? –  YumYumYum Oct 19 '11 at 11:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.