Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am on Arch Linux with Kde.

I haven't updated the packages in a while and I'm having a problem while trying to do so:

The first thing I tried was: sudo pacman -Syu as the documentation says, and I get this error:

:: Synchronizing package databases...
 testing is up to date
 core is up to date
 extra is up to date
 community is up to date
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: packagekit: requires pacman<3.6.0
:: package-query: requires pacman<3.6

I checked what version of pacman I had and I have v3.5.4:

 .--.                  Pacman v3.5.4 - libalpm v6.0.4
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2011 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.

Which seems to be ok I guess?

Just in case I tried to first update yaourt and I got the same message:

 testing is up to date
 core is up to date
 extra is up to date
 community is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: packagekit: requires pacman<3.6.0
:: packagekit: requires pacman<3.6.0

I ran the following command to see if I could get the useful information and got this from where I couldn't get any more useful information, but maybe you can.

Just in case I also tried it with KPackageKit and also got the same error:

:: packagekit: requires pacman<3.6.0
:: packagekit: requires pacman<3.6.0

I hope you have all the information you need, otherwise please ask. Thanks in advance.

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

There are two separate, but related, issues. First, package-query is an unsupported package (from the AUR) and it is your responsibility to rebuild it whenever other dependencies—in this case pacman—are updated.

Uninstall it, update pacman and then rebuild package-query against the newer version.

Second, in addition to Shawn's advice to force resynch your package list, you should ensure that you are synching to an up-to-date mirror.

share|improve this answer
add comment

The first step would be to force a refresh of the master package list. This is done by pacman -Syy. Once that's done, try pacman -Syu again.

share|improve this answer
    
Nope, no luck! :( –  Trufa Oct 18 '11 at 20:19
1  
If you do pacman -Syy there's no need to do pacman -Syu later. I mean, you can either run pacman -Syy && pacman -Su or pacman -Syyu. –  Francesco Turco Sep 15 '12 at 10:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.