Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to add a new APT repository using this command:

add-apt-repository ppa:atareao/atareao

but I got a "command not found" error. I tried installing python-software-properties, but it's already installed:

root@debian:~# apt-get install python-software-properties
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-software-properties is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So I decided to add the repository manually to source.list, but don't know how. How can I edit source.list directly?

share|improve this question
See the answer by @Broam and others at askubuntu.com/questions/38021/how-to-add-a-ppa-on-a-server. – denten Jul 31 '14 at 14:56
up vote 2 down vote accepted

If you visit the PPA's page it'll show you what lines to manually insert into the source.list

Click on Technical Details which reveals the following

enter image description here

Choose your Ubuntu version and copy/paste the lines into the bottom of your source.list file.

share|improve this answer
Nice, thx Marco :) – Maistora Oct 16 '11 at 16:15

One year after your post, I had the same issue on Ubuntu 12.10 I figured out how to bypass the problem (not really to fix it) so I take the time to post a reply just for the record. We never know, if anybody face this problem after me.

The FIX (kind of)

apt-get install software-properties-common

The explaination (kind of)

It seems there is a dependancy issue on this package(s) https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1024408

Proof (kind of)

You can see the python-software-properties doesn't include the add-apt-repository binary :

dpkg -L python-software-properties

While the software-properties-common does :

dpkg -L software-properties-common
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.