Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've tried following the Ubuntu hotkeys/media keys troubleshooting guide and /usr/share/doc/udev/README.keymap.txt.gz to make the Fn keys work. After copying the map file and modifying /lib/udev/rules.d/95-keymap.rules I get the correct key names from sudo /lib/udev/keymap -i input/event4, but none of them do anything at all.

How do I make sure that at least wlan and kbdillumup/kbdillumdown work?

$ /lib/udev/findkeyboards
AT keyboard: input/event4
$ cat /sys/class/dmi/id/sys_vendor
SAMSUNG ELECTRONICS CO., LTD.
$ cat /sys/class/dmi/id/product_name
90X3A

samsung-90x3a map file:

0xCE prog1 # Fn+F1 Unknown
0x8D prog3 # Fn+F6 Economy mode
0x97 kbdillumdown # Fn+F7 Keyboard background light down
0x96 kbdillumup # Fn+F8 Keyboard background light up
0xD5 wlan # Fn+F12 Wifi on/off

$ udevadm info --export-db

Update: The information below will be from Arch Linux since I no longer have Ubuntu.

xdotool key XF86KbdBrightnessUp prints nothing, but returns with exit code 0. I'm not sure if that means anything.

acpi_listen prints nothing when pressing Fn+F7/Fn+F8.

share|improve this question
    
Some 90x3a owners have managed to make Fn+F7 and Fn+F8 work after updating to the latest BIOS and following jablonskis tutorials. –  don_crissti Apr 18 '13 at 15:23
3  
You can test whether your kernel is supporting these functions on your laptop with xdotool. Try xdotool key XF86KbdBrightnessUp and see if you get the expected results. –  drs Apr 23 '13 at 17:39
    
what acpi-listen give you when you type Fn+f7 ? –  Kiwy Nov 29 '13 at 10:22
    
@chirp - did you try the jablonskis tutorial‌​. Did that not solve the issue for you? –  slm Nov 30 '13 at 2:38
1  
here is how you associate a keypress to a command with KDE: linuxintro.org/wiki/Configure_your_multimedia_keys –  Thorsten Staerk Dec 18 '13 at 15:39

1 Answer 1

Quite often, to get the backlight adjustment to work, you need to edit your GRUB configuration to contain the following:

GRUB_CMDLINE_LINUX_DEFAULT="splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

That worked for enabling backlight controls on most of my laptops.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.