Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently i'm using flow redirect to enable auto login mode , but when i launch tmux in tty1 , it stuck.

c1:12345:respawn:/bin/login -f USERNAME</dev/tty1 > /dev/tty1 2>&1

Is there any better solution for this ?

share|improve this question
up vote 3 down vote accepted

The problem is that the redirections are not enough to have /dev/tty1 be considered as the controlling terminal for the login session.

Why not to use the -a (autologin) option from agetty? Example:

c1:12345:respawn:/sbin/agetty -a USERNAME 38400 tty1 linux
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.