Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running SuSE 11.2. I also have windows and Ubuntu on the same machine. The problem is that I cannot get Ubuntu to show as a boot option on SuSE's grub. The Ubuntu partition is on /dev/sda5. Here is my /boot/grub/menu.lst:

# Modified by YaST2. Last modification on Wed Sep 15 13:08:06 SAST 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.31.12-0.2-desktop root=/dev/disk/by-id/ata-ST3160815AS_9RX3KRP8-part3 resume=/dev/disk/by-id/ata-ST3160815AS_9RX3KRP8-part2 splash=silent quiet showopts vga=0x31a
    initrd /boot/initrd-2.6.31.12-0.2-desktop

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.2 - 2.6.31.12-0.2
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.31.12-0.2-desktop root=/dev/disk/by-id/ata-ST3160815AS_9RX3KRP8-part3 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
    initrd /boot/initrd-2.6.31.12-0.2-desktop

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1

#Don’t change this comment – YaST2 identifier: Original name: none#
title Ubuntu 10.04
    root (hd0,4)
    kernel /vmlinuz root=/dev/sda5 ro quiet splash
    initrd /initrd.img
share|improve this question
    
To avoid confusion, please be explicit about what version of grub you are using, whether grub legacy or grub 2. For preference, quote the version number. The config file does look like grub legacy, but is your system running grub legacy? –  Faheem Mitha Mar 18 '11 at 9:32

4 Answers 4

Try chainloading the version of GRUB Ubuntu ships with instead of using the same GRUB from SuSE:

title Ubuntu 10.04
    root (hd0,4)
    chainloader +1

This way Ubuntu will manage it's own GRUB configuration and kernel upgrades on it's own partition.

share|improve this answer

Did you try doing that from YaST->Boot Loader->Choose Image and then fill all the other options like your kernel image etc and you are done :)

share|improve this answer
    
I cannot see the ubuntu options from within YaST->Boot Loader->Choose Image –  Vaolter Sep 17 '10 at 14:10

I believe that the ubuntu options are located in /etc/grub.cfg. It will take some parsing; that file on my system looks like a whole shell script, but the tail end looks like you should be able to parse it out sufficiently to get what you need.

share|improve this answer
    
I am only able to boot from suse now so help access my ubuntu partition. –  Vaolter Sep 18 '10 at 9:46
1  
If you type mount /dev/sda5 /mnt(either as root or with sudo), then you should be able to access the root of your ubunto partition at /mnt. –  Kevin M Sep 18 '10 at 21:37
    
This is a red herring, it should be the grub from SuSe running. –  pjc50 Mar 7 '11 at 16:35

Your syntax looks correct. I have a few recommendations. First try taking off the quiet splash. Secondly I would list the full path to the kernel and initrd image.

title Ubuntu
    root (hd0,4)
    kernel /boot/vmlinuz-<ubuntu-kernel-version> root=/dev/sda5 ro
    initrd /boot/initrd-<ubuntu-kernel-version>

Lastly, make sure you update grub.

  grub --batch --device-map=/boot/grub/device.map < /etc/grub.conf

Caveate: I don't use SUSE, I found that command here. Hope this helps.

share|improve this answer
    
You shouldn't need to update grub just because the menu/configuration has changed. Perhaps, if the device.map needs updating because a disk was added, but grub reads it's configuration from disk on each boot unlike lilo. –  penguin359 Mar 31 '11 at 9:13
    
@penguin359 True, but I don't know what state everything is in. Updating grub will ensure that it's correct. –  bahamat Apr 1 '11 at 19:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.