Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used KRec to record some audio, but when I played it back I got nothing. What are the things I need to do to figure out where the problem is? My computer is a Dell OptiPlex DX620, Intel Pentium 4 3.00 GHz running Fedora 7 (Moonshine)

share|improve this question

2 Answers 2

Did you remember to check the volume settings? It looks like the program for this in KDE is kmix.

(Yes, I know this is like asking if you remembered to plug in your computer and connect your monitor when you complain that the screen is blank, but everyone misses those steps once in a while...)

share|improve this answer
1  
Indeed, sometimes to get audio output you need to set more than one volume control to a large enough value (and sometimes your mixer doesn't show all the necessary controls!). Input is usually simpler, but still, checking the volume(s) can be a nonobvious step. –  Gilles Sep 16 '10 at 19:44
    
In addition make sure that the module (or whatever it's called I don't mean kernel module) for input is turned on! alsa leaves everything off by default it seems. –  xenoterracide Sep 16 '10 at 21:04
    
I use Linux all the time to build software but I seldom use it as a desktop, so I'll try kmix tomorrow when I go back to work. Thanks for the suggestions. –  grokus Sep 16 '10 at 21:34
    
@gro any update? –  Tshepang Jan 23 '11 at 20:49
1  
@Tshepang, sorry I gave up. I don't work there anymore so don't have to worry about that anymore. Extremely happy with my MacBook now. –  grokus Jan 23 '11 at 21:01

You might also need to select the input device. Those controls are usually in extended settings in your mixer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.