Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I typically dual boot my laptop betwen a Win7 and Ubuntu partition, but keep a spare partition for playing around with new distros. Earlier this week, I decided to try out Debian Squeeze.

For the most part, the install has gone smoothly. However, the wireless is not working, and this is apparently a well known issue for Debian. The thing is, my wireless card apparently requires the iwlagn firmware iwlwifi-5000-5.ucode. I downloaded the updated 0.33 package that supposedly includes this firmware and installed it using the package manager.

It still isn't working, as dmesg | grep firmware returns 'looking for firmware v5, found v0'

This laptop is over 2 years old and I have zero problems with networking in Ubuntu Maverick. Any solutions?

share|improve this question
    
There is a package in backports, have you tried that? packages.debian.org/squeeze-backports/firmware-iwlwifi –  jasonwryan Sep 26 '11 at 23:22
    
Tried and didn't work. Wired ethernet works fine, not wireless. I can see the package contains the 5000-5.ucode firmware, but its not loading at all for some reason –  Jason Sep 27 '11 at 0:41
    
Have you installed wireless-tools and modprobed the module? –  jasonwryan Sep 27 '11 at 0:43
    
I have. However, I'm unsure if modprobe is working, since su modprobe iwlagn produces no output on the CL –  Jason Sep 27 '11 at 1:10
1  
Can you please update your post with details of your kernel and card? –  jasonwryan Sep 27 '11 at 1:52
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.