Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an issue where most often my screensaver will not activate and it's somewhat hard to determine what's preventing it. Is there a way that I can view whatever processes are asking the OS not to display the screensaver?

I'm on Linux Mint 11.

share|improve this question

2 Answers 2

I guess your mouse is doing tiny movements. It`s been a while, but I experienced this strange behaviour with a mouse that was reacting to sunlight.

So try to remove your mouse...

share|improve this answer
    
Did that, that didn't help. –  Naftuli Tzvi Kay Oct 4 '11 at 3:32
    
I am out of ideas here. I once tried to research some things about DPMS and did not come up with much information. –  Nils Oct 4 '11 at 20:47
up vote 0 down vote accepted

I simply went to Screensaver Preferences:

enter image description here

Made sure that Activate screensaver when computer is idle was checked.

Then, I ran killall gnome-screensaver, then restarted the screensaver with gnome-screensaver. Voila, it worked. How/why, I'm not sure.

As far as having the output shut off, this isn't working yet, but I think it's because I have a weird setup (laptop lid shut, output to two monitors over HDMI and VGA).

share|improve this answer
    
Also: I had to prop open my laptop lid in order to get the monitors to shut off as per the setting in "Power Management." –  Naftuli Tzvi Kay Nov 28 '11 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.