Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Gnome in Ubuntu 11.04. I work a lot in Emacs, and I find that the Gnome window manager grabs some of the Emacs keys. To some extent, I can stop this by laboriously going through each of System->Preferences->Keyboard shortcuts and disabling the offending keys. However it would be nice to do this once for everything. In addition, my latest problem is with org-mode, M-S-up should be org-shiftmetaup (org-move-subtree-up) but the window manager is grabbing that key combination and making shrunken windows. However, I cannot find that in the Keyboard Shortcuts list; I don't use it and have no idea what they call it (and it doesn't seem you can look up/edit the short cuts by key combination, only by name).

So my questions are:

  1. Is there one Gnome configuration change I can make that will by default disable all keyboard short cuts?
  2. Is there then a way to re-enable some of them? (I don't use them much, but might want a couple that don't conflict with Emacs.)
  3. Failing that, is there a way to disable shortcuts that conflict with Emacs, for instance by moving Meta to the Super key for Gnome only and not emacs?
  4. Short of 3, is there a way to find a shortcut by the key combination so it can be disabled individually?
share|improve this question
    
Are you using compiz+unity, compiz (ubuntu classic) or metacity (ubuntu classic without effects)? –  enzotib Sep 24 '11 at 16:54
    
Ubuntu classic (not unity), I think I do have the effects. –  Liam Sep 24 '11 at 18:05
add comment

1 Answer

Move the Meta key to the Windows keys in your keyboard settings (“Keyboard Preferences → Layouts → Options → Alt/Win key behavior → Meta is mapped to Win keys”. The window manager will still use Alt, and Emacs will use Meta.

share|improve this answer
    
Just tried it, and it doesn't make any difference for me. The ungrabbed Alt key still behaves as meta, and Emacs thinks I'm pressing super when I press the win key. I can see this being a solution if it worked, but it would be a bit better if I could change Gnome's behavior rather than Emacs', since I use Emacs Meta all the time, and Gnome's Alt just about never. In fact disabling all window manager keyboard shortcuts would probably work well for me. –  Liam Sep 25 '11 at 2:52
    
@Liam: You'll have to restart Emacs after making the change. –  Teddy Sep 25 '11 at 3:03
1  
OK thanks. I tried it and it's not really what I was looking for. My title is "Gnome stop grabbing my emacs keys" not "Emacs stop having your keys grabbed by Gnome". Does one of those keyboard mapping options (there are a lot) move Gnome's Alt to the win key, and leave meta on Alt? –  Liam Sep 28 '11 at 2:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.