Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In Slackware, when I use the command "Xorg -configure" to setup the X server, I get the following:

(EE) Failed to load module "vmwgfx" (module does not exist, 0).
(EE) vmware: Please ignore the above warnings about not being able to load module/driver vmwgfx (???)
(EE) vmware: unexpected failure while loading the "vmlegacy" driver. Giving up.
(EE) LoadModule: Module xgi does not have a xgi ModuleData data object.
(EE) Failed to load module "xgi" (invalid module, 0)
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d".

Because of this, when I test the Xserver, all I get is a blank screen. What can I do to fix this? I'm running a Gateway NV57H laptop with an intel graphics card.

update

Problem fixed. While I wasn't able to test the X server from the commandline, I was able to make my distro restart into the x server. This problem has now been solved.

share|improve this question
    
I had this issue a couple of days ago. I then uninstalled all unneeded xorg video drivers and after that it worked... –  janoliver Sep 23 '11 at 18:32
    
how do I do that? –  Holland Sep 23 '11 at 18:35
    
I don't know about slackware, I was using pacman which comes with arch linux. –  janoliver Sep 23 '11 at 19:47

1 Answer 1

up vote 1 down vote accepted

If you're testing the X server by just running Xorg, then a blank screen is the expected result on current Xorg versions - it stays black until programs connect and tell it to draw something. For standalone testing, you probably want to specify the -retro flag to restore the old gray backdrop and default X cursor.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.