Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a dual monitor setup, with a small (laptop) and a bigger screen. Whenever I watch a video on some streaming website, and click fullscreen, the video takes the resolution of the smaller screen (1366x768) but shows up on the big screen (1920x1080). The remaining space on the right and below the video is just grey. I, of course, want the video to be fullscreen on the bigger monitor, and not just 1366x768.

Note: This is not the problem where the fullscreen is always displayed on the primary monitor. For me, it doesn't matter whether the secondary monitor is primary or not and even if I switch off the smaller screen using xrandr, and only use the large monitor, the issue remains. I am not 100% sure if the video really takes 1366x768 but I guess it does.

I am using openbox as window manager. Any suggestions?

share|improve this question
add comment

2 Answers

I have the same issue with dual monitor setup using radeon driver

Here's the same issue elsewhere:

http://askubuntu.com/questions/36820/how-to-make-youtube-fullscreen-actually-fullscreen

One answer to that post links to

http://al.robotfuzz.com/content/workaround-fullscreen-flash-linux-multiheaded-desktops

It's a dirty hack, and the author has nvidia hw with the vendor driver, but sounds it seems likely to work (for some value of "work").

share|improve this answer
add comment

This is probably because you change X to dual-monitor setup after you started the window manager (this also depends on the WM, but it looks like openbox has a problem here). To solve this, you should start dual-monitor before starting openbox. If you use startx (or an entry like my custom Xinit script at the DM) to start the desktop environment, you can put something like that in your .xinitrc:

xrandr -q | grep "VGA1 connected" && \
    (
     xrandr --output VGA1 --mode 1920x1080 --left-of LVDS1
     xrandr --output LVDS1 --pos 1920x800
    )
share|improve this answer
    
I already am doing something like that; I use slim, in /etc/slim.conf I have this line: login_cmd exec ck-launch-session /bin/bash -login ~/.xinitrc %session. The file .xinitrc looks like this: xrandr --output LVDS1 --mode 1366x768 --output HDMI3 --mode 1920x1080 --right-of LVDS1 ... and after that the openbox star command exec openbox-session. So... xrandr is executed before openbox is started... –  janoliver Sep 19 '11 at 22:46
    
Hmmm, that's strange. Can you try running some other WM, (like a basic twm even) in place of openbox in your script? And another browser..? –  rozcietrzewiacz Sep 20 '11 at 6:05
    
Also, could you paste a stripped version of your xorg.conf? Maybe the X server does not define large enough Viewport. –  rozcietrzewiacz Sep 20 '11 at 6:09
    
I don't have an xorg.conf and neither do I have anything regarding the viewport in /etc/X11/xorg.conf.d/*. However, in XFCE4 it does work. So it seems to be a problem with openbox... –  janoliver Sep 20 '11 at 7:08
    
Yes, it looks like openbox issue - but it might be solved if Xorg was setup better. Try running Xorg -configure and then startx -- -config xorg.conf.new. I believe openbox may rely on incomplete information reported by Xorg server, whereas Xfce probes setting more thoroughly. –  rozcietrzewiacz Sep 20 '11 at 7:19
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.