Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I created a RedHat 6.1 VM with EC2. Logged in as root, I installed (unzipped) JDK1.7 in /root/bin/jdk1.7.0 and installed (unzipped) GlassFish 3.1.1 in /root/bin/glassfish3. I set JAVA_HOME and GLASSFISH_HOME in root's .bash_profile and I started GlassFish.

It's definitely running, because if I do a wget localhost:8080 from the command line, wget downloads the index.html file. The problem is, when I browse to the machine at http://ec2-107-20-96-43.compute-1.amazonaws.com:8080, I get nothing.

I added port 8080 to the VM's security group; is there something else I have to do there? Is there something else I have to do on the linux machine to make 8080 visible?

share|improve this question
    
Are you sure that your server is listening on your forward-facing interface? –  Chris Down Sep 16 '11 at 2:44
    
@Chris - thanks for the suggestion; it looks like the problem was with the EC2 security group settings –  Robert Hume Sep 16 '11 at 3:02
    
Just a suggestion: don't start glassfish as root and don't install software in root's home directory. On the security point of view it's a very bad idea. –  Matteo Apr 13 '12 at 8:45

1 Answer 1

up vote 0 down vote accepted

I spent some more time with the EC2 security groups. I allowed all incoming TCP ports and it looks like it's working now. I guess I didn't have port 8080 open correctly.

share|improve this answer
    
Remember to accept your answer; otherwise it keeps coming back for others to attempt to answer. –  Michael Hampton Aug 11 '12 at 18:30
    
@MichaelHampton Thanks! –  Robert Hume Aug 14 '12 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.