Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to set up rtorrent on my CentOS 5.6 server, and it currently cannot connect to any trackers.

I compiled libtorrent-0.12.6 and rtorrent-0.8.6. I also compiled libcurl 7.21.7 with c-ares 1.7.5 because the in-repo version of curl didn't have c-ares so it couldn't resolve tracker host names (not asynchronously at least).

I forwarded ports 6890-6999 through iptables using the following in /etc/sysconfig/iptables:

-A INPUT -p tcp --destination-port 6890:6999 -j ACCEPT
-A OUTPUT -p tcp --source-port 6890:6999 -j ACCEPT

But even if I stop iptables it doesn't work.

When I start rtorrent it will say something like Connecting to http://torrent.fedoraproject.org:6969/announce, then quickly followed by Couldn't connect to server.

I know there isn't much information about why it can't connect, but is there a way I can find out?

Edit I tried rtorrent on my local machine running Fedora 15 using all in-repo software and I have the same problem. But ktorrent runs on Fedora 15 with no problem.

share|improve this question

1 Answer 1

Do you have those ports forwarded on your router ? - Im willing to bet ktorrent works due to DHT connections, and actually none of them work properly.

its hard to say if those iptables rules will work as it depends on the rest of the rules, but by defualt iptables has a default accept (iptables -P INPUT ACCEPT) so no iptables rules are needed.

My guessing is this isnt actually an issue on the linux machine.

share|improve this answer
    
DHT was actually turned off in Ktorrent. The company hosting my CentOS server has told me before that they don't block any ports. –  jonescb Sep 14 '11 at 14:05
    
Forwarding is not the same as unblocking -- is the server directly connected to the Internet? I mean, does it have a dedicated WAN IP address? If it doesn't, then the issue is that (maybe ktorrent supports UPnP and that's why it manages to work). –  njsg Feb 14 '12 at 19:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.