Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently formatted an entire drive so I could install Linux on it. The partitions:

15 GB, Primary, sda1, mount point: /
232.9 GB Logical, sda5, mount point: /home
3 GB Logical, sda6, swap

However, upon install completion (with the GRUB bootloader) and reboot, the BIOS reports that it cannot find a bootable device.

I am thinking that I did not set sda1's bootable flag. If this is the case - is there some way I can do this from the Debian CD's "rescue mode"?

The exact error message from the BIOS is No bootable device -- insert boot disk and press any key.

Attempted:

  • Removed all other boot options (CD, USB) from the boot list
  • Swapped cabled
  • Tried other SATA ports
  • Swapped hard drives (with new SSD)
share|improve this question
1  
The bootable flag isn't read by the BIOS, it's read by some bootloaders (but not the ones most commonly used for Linux). What bootloader did you install? What's the exact error message from the BIOS? And yes, this is likely to be fixable from the CD, look for a way to repair Grub (I think there's a menu entry for that). –  Gilles Sep 11 '11 at 18:40
    
Thanks for the comment Gilles - I've added the message I received. –  Julian H. Lam Sep 11 '11 at 18:55
    
Do you have multiple disks? Is that an internal disk or an external one (e.g. USB)? –  Gilles Sep 11 '11 at 19:45
    
I am installing to an internal SATA Hard Drive via an ISO burned to a CD. I have tried booting into rescue mode and running grub-install /dev/sda, which did nothing. There were no errors (that I could see) during installation. –  Julian H. Lam Sep 11 '11 at 20:29
    
Upon booting into a rescue shell and inspecting the file structure, I can see that the files all exist, so as far as I can tell, the hard drive is not at fault here. –  Julian H. Lam Sep 11 '11 at 21:03

4 Answers 4

I am posting here Gilles answer :

The bootable flag isn't read by the BIOS, it's read by some bootloaders (but not the ones most commonly used for Linux). [...] And yes, this is likely to be fixable from the CD, look for a way to repair Grub (I think there's a menu entry for that).

share|improve this answer

I would disable everything booting except the harddrive and see if you can boot it. If you really can't boot from it, boot in live and run a diagnostic on the drive with smarttools. You can usually get away with a short test (takes about two minutes).

share|improve this answer
    
Thanks Zeroedout, I'll give that a try tonight. –  Julian H. Lam Sep 14 '11 at 19:50
    
Disabling everything except the Hard Drive didn't change anything. It seems as though that particular message comes up when it has exhausted all boot options. –  Julian H. Lam Sep 17 '11 at 19:09

Did you install grub to /dev/sda1 or to /dev/sda? It should be /dev/sda.

share|improve this answer
    
Whichever debian defaulted to (which would probably be /dev/sda). I also tried booting into the CD's rescue mode, and ran install-grub /dev/sda, but to no avail. I also purchased a new hard drive, so the drive is not at fault here. Perhaps the cable or the SATA controller... –  Julian H. Lam Sep 14 '11 at 19:50

Yes, that particular message comes up when it has exhausted all boot options.

By chance, may it be that you disabled other boot option, but your hard drive is not the first option and there is some BIOS option to only try one (first) option? I've seen such configurations before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.