Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using freenas and have a samba share that I'm accessing from a windows machine.

When I browse to the share I can view all directories except one ("ProblemDirectory" below). I can navigate to this directory directly, but it only shows up in the folder list if I uncheck "hide protected operating system files" in Windows explorer.

I don't understand what is different about this one directory. Permissions all look the same:

drwxrwxrwx    8 root  wheel          512 Sep 11 16:37 .
drwxrwxrwx    4 root  wheel          512 Apr  6  2010 ..
drwxrwxrwx    2 ftp   wheel         1024 Sep 27  2010 Directory1
drwxrwxrwx   12 ftp   wheel          512 Apr 18  2010 ProblemDirectory
drwxrwxrwx  827 root  wheel        19968 Aug 14  2010 Directory3

How can I "unhide" this directory?

share|improve this question
    
What are the extended attributes on the directory? –  Ignacio Vazquez-Abrams Sep 11 '11 at 17:51
    
What's the command for this in FreeBSD? –  Ben Sep 11 '11 at 18:26
    
What are your settings in Samba. You can set a directory as browseable or not in the samba config. You may have inadvertantly set it not be be browseable. –  user10778 Sep 15 '11 at 22:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.