Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Here's the minimal requirements:

  1. two-fingers movement on touchpad for scroll
  2. using the lower-powered GPU as default card
  3. sleep on lid close
  4. some key (control or command) + LMB for RMB


  • "squeeze" gesture to zoom in
  • working multimedia keys
  • GPU switching on-the-fly

If you know a distro that qualifies, can you also mention all extra features you know it supports.

share|improve this question
3 and 4 are easy, I think 1 and 2 are achievable but requires tweaks. Anyway here you go – phunehehe Sep 10 '11 at 14:14
There are quite a lot of Arch users with Macbooks: the wiki has a detailed run down: - most of what you ask looks straightforward – jasonwryan Sep 10 '11 at 19:08
Thank you both, but guys, why are you just commenting instead of posting an answer? ;-) – greenoldman Sep 11 '11 at 6:48

5 Answers 5

up vote 7 down vote accepted

I have arch linux installed on my Macbook Pro 7.1 & everything works perfectly.

For special keys -> pommed Touchpad driver -> default works fine (has two finger scroll & three finger middle click pre-configured).

I am not really sure about the two GPU things as I have only one Nvidia 320M. Sleep on closing lid is pretty easy.

share|improve this answer
I am not able to get my ARCH recognized by EFI. Arch documentation is extensive in this regard. But, it is not working for me. Can you point to any blog or offer any tips? – Salil Feb 22 '13 at 20:44
I wrote this blog post when I was triple-booting my Mac.… – Abhijeet Rastogi Feb 23 '13 at 11:47
I have Arch Linux on MacBook Pro 11,5, and everything doesn't work perfectly. It's gotten quite annoying. Gnome Desktop doesn't work with the nvidia drivers unless you do a hack where you start cinnamon, then gnome-shell --replace. Bluetooth devices don't show up in gnome-bluetooth settings. Suspend only works the first time, after that it always wakes up right after suspending, and the screen stays on when the lid is closed. Backlight on the screen is not adjustable, and the keybord backlight doesn't turn on at all. – trusktr Oct 31 at 22:48
Wifi only works with the broadcom-wl driver, which periodically needs to be re-installed after updates to the kernel which leaves you without WiFi and only ethernet to fix it. I used to love Arch Linux on my older laptop and desktop, which had older hardware that was widely supported in the Linux world, but now, everything is a pain on this Macbook. I felt bad ass making it dual boot with OS X, but it's taking time away from developing my personal projects. I wonder how Ubuntu or Fedora fare... – trusktr Oct 31 at 22:49

Ubuntu 12.04 and Mint 11 are both rough going. Trackpad support is minimal, though slightly better in Ubuntu than Mint. Even with tweaks, neither works well. No easy answers if you need to run a second monitor. Wireless keyboard and magicmouse... won't work. Even hours spent researching these issues will get you nowhere. Ubuntu forums offer no easy answers, either.

However, there is hope... The problem is with GNOME/Unity, not Linux. in the GNOME/Unity DE, the the GUI's are not present. KDE is a different story. Within a few minutes with just the included system tools, I got the trackpad working as I wanted it to using KDE on top of a standard Ubuntu installation. Still, no second monitor, no bluetooth with Apple products. If all you need is the self-contained Macbook with no need for a bluetooth mouse, keyboard, or second monitor, then KDE... probably from any distro... is best.

share|improve this answer

It is vastly the kernel that determines compatibility with the hardware and its quirks rather than the distribution. Perhaps the only thing that would really matter in terms of the distribution is whether the default kernel for that operating system was lacking support for some of your hardware, or modules or other packages required for your hardware were not immediately accessible via the package manager, but for such commonly seen hardware as a MacBook Pro, I think you'd struggle to find a distribution that didn't have adequate support.

With that said, there is very good documentation on the Arch Wiki (marked out of date, but the vast majority of the document should still be relevant regardless) on running Arch on a Macbook here. Most of that should be also applicable to other distributions, though, it is mostly up to the kernel to determine compatibility, although some specific functions (such as the multitouch scroll you describe) would likely fall under the remit of other software.

share|improve this answer
Arch Linux on my MacBook Pro 11,5 has been a pain. – trusktr Oct 31 at 22:50

I run custom arch linux on my macbook dual booted with osx. Ubuntu works good mostly out of the box. Arch works better with a lot of tweaking. I had to install the zen kernel through chroot using an ubuntu live cd just to get it to boot. I used to compile the kernel myself now I use the one in the hertsig repo.

Installed pommed, nvidia proprietary drivers, nvidia-bl. 3d effects work. I forget how I got two and tree finger scrolling/clicking but two finger tap is middle click and three finger is right click. It amuses me that a quick google search says it's impossible to run on the mbp 7.1 but I've been running it for over year now. Most kernels won't run because of some sata bug. Zen kernel, ubuntu kernel. Are what worked for me.

share|improve this answer

I have spent a couple of weeks benchmarking some linux distros like

  • Mint with cinnamon desktop environ.
  • Ubuntu, the new debian 7.4
  • Fedora
  • CentOS
  • elivecd

And I have Elivecd installed because the full support of the mac hardware, i.e. WiFi chipset, and elive works pretty fluently.

share|improve this answer
what were the tests results? – Thiago F Macedo Jun 12 '14 at 21:17
I tried the lived but I didn't managed to boot it, are you using a third party boot loader? – Samantha Catania Oct 20 '14 at 9:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.