Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have the exact same Emacs configuration on a local and remote machine, and when I run M-x ansi-term or M-x term on each of them individually everything works great.

However, if I run any of these term emulators on Emacs on the local machine, and then I ssh into the remote machine, the prompt is not displayed correctly and my input doesn't work well either.

Any ideas what may be causing this?

share|improve this question
Do you have the same Emacs versions? Same distributions? Same locale settings (locale -a)? What do you mean by “not display correctly” and “doesn't work well”: describe precisely what you see and how it differs. –  Gilles Nov 26 '11 at 0:16
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.