Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In Synaptic I am getting the error:

acroread: 
  Depends: acroread-l10n-en but it is not going to be installed or acroread-l10n 
  Depends: acroread-debian-files but it is not going to be installed 
  Depends: acroread-data but it is not going to be installed 
  Depends: ia32-libs-xulrunner but it is not going to be installed 

This is unusual for me as Synaptic normally resolves dependencies automatically; moreover acroread is a very popular package.

I want to know how to get around this.

I'm on Deb 6 64 bit.

acroread is being sourced from deb http://www.debian-multimedia.org squeeze main non-free.

For possibly relevant details also see Security hurdles to enabling sources in repo.

Edit (@enzotib):

# Debian packages for stable
deb http://mirror.transact.net.au/debian/ stable main contrib non-free
# Uncomment the deb-src line if you want 'apt-get source'
# to work with most packages.
# deb-src http://mirror.transact.net.au/debian/ stable main contrib non-free

# Security updates for stable
# deb http://security.debian.org/ stable/updates main contrib non-free

deb http://www.debian-multimedia.org squeeze main non-free
#contains Adobe Reader

@Gilles

peter@peter-deb:~$ apt-cache policy acroread acroread-debian-files ia32-libs-xulrunner
acroread-debian-files:
  Installed: (none)
  Candidate: 9.4.2
  Version table:
     9.4.2 0
        500 http://www.debian-multimedia.org/ squeeze/main amd64 Packages
acroread:
  Installed: (none)
  Candidate: 9.4.2-0.0
  Version table:
     9.4.2-0.0 0
        500 http://www.debian-multimedia.org/ squeeze/non-free amd64 Packages
ia32-libs-xulrunner:
  Installed: (none)
  Candidate: 1.8.1.3-0.5
  Version table:
     1.8.1.3-0.5 0
        500 http://www.debian-multimedia.org/ squeeze/main amd64 Packages

@Gilles:

peter@peter-deb:~$ sudo aptitude install acroread
The following NEW packages will be installed:
  acroread acroread-data{a} acroread-debian-files{a} 
  acroread-dictionary-en{a} acroread-l10n-en{a} ia32-libs{a} 
  ia32-libs-gtk{a} ia32-libs-xulrunner{a} lib32asound2{ab} lib32bz2-1.0{a} 
  lib32gcc1{a} lib32ncurses5{a} lib32stdc++6{a} lib32v4l-0{a} lib32z1{a} 
  libc6-i386{a} 
0 packages upgraded, 16 newly installed, 0 to remove and 8 not upgraded.
Need to get 4,955 kB/102 MB of archives. After unpacking 254 MB will be used.
The following packages have unmet dependencies:
  lib32asound2: Depends: libasound2 (= 1.0.23-2.1) but 1.0.24.1-2 is installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     acroread [Not Installed]                           
2)     acroread-data [Not Installed]                      
3)     acroread-debian-files [Not Installed]              
4)     acroread-dictionary-en [Not Installed]             
5)     acroread-l10n-en [Not Installed]                   
6)     ia32-libs [Not Installed]                          
7)     ia32-libs-gtk [Not Installed]                      
8)     ia32-libs-xulrunner [Not Installed]                
9)     lib32asound2 [Not Installed]                       



Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

More error info:

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Unable to lock the download directory
share|improve this question
    
Can you show the content of /etc/apt/sources.list and of all files matching /etc/apt/sources.list.d/*.list? –  enzotib Sep 2 '11 at 17:46
    
@enzotib Ok, I have posted the contents of my sources.list file, but what am I supposed to retrieve for /etc/apt/sources.list.d/*.list? Any why is the wildcard (*) included? –  ptrcao Sep 2 '11 at 21:43
    
enzotib meant to post every file called something.list in the directory /etc/apt/sources.list.d. Debian-multimedia no longer provides acroread, does it? What does apt-cache policy acroread acroread-debian-files ia32-libs-xulrunner say? –  Gilles Sep 2 '11 at 22:24
    
@Gilles: See OP for output. What command do I need to issue for to get a list for /etc/apt/sources.list.d/*.list? –  ptrcao Sep 2 '11 at 22:29
    
The command would be /etc/apt/sources.list.d/*.list, but I don't think this information is needed (apt-cache policy already gives the relevant parts of that). Hmmm, you should be able to install. If you have a file /etc/apt/preferences, post it. And try aptitude install acroread, it may be cleverer or have a better error message. –  Gilles Sep 2 '11 at 22:45

2 Answers 2

After seeing your previous question, it looks like you've just installed the Debian Multimedia repository keyring. Installing the package automatically registers the signing key with apt-key, but the signature is verified when you download the package list (i.e. during an update operation). As long as you haven't done that, the packages from the Debian Multimedia repository are untrusted and therefore (if I remember correctly) not installable through Synaptic by default.

If this is indeed the problem, just run apt-get update (or the update command in Aptitude or Synaptic) once after installing the debian-multimedia-keyring package.

share|improve this answer
    
I'm afraid the problem persists after doing so... Also see output for aptitude in OP above. –  ptrcao Sep 3 '11 at 1:54
    
this information about my system could be relevant: unix.stackexchange.com/questions/19898/…. It is from yet another problem I was having earlier that concerns my sources.list. –  ptrcao Sep 3 '11 at 2:02

Analysis of problem above. Quoting from the post:

The following packages have unmet dependencies:
  lib32asound2: Depends: libasound2 (= 1.0.23-2.1) but 1.0.24.1-2 is installed.
The following actions will resolve these dependencies:

This means that lib32asound2 has libasound2 as a dependency. However, the version of libasound2 installed (1.0.24.1-2) is of higher version number than that required by lib32asound2 (1.0.23-2.1). This is causing errors for the package manager (aptitude), since without special prompting it will not downgrade the package to a lower version.

As posted, the version information is

libasound2: 
  Installed: 1.0.24.1-2 
  Candidate: 1.0.24.1-2 
  Version table: 
  *** 1.0.24.1-2 0 500 http://mirror.transact.net.au/debian/ testing/main amd64 Packages 
        100 /var/lib/dpkg/status

This seems to be missing the stable version. I have

$ apt-cache policy libasound2
libasound2:
  Installed: 1.0.23-2.1
  Candidate: 1.0.23-2.1
  Version table:
     1.0.24.1-3 0
         50 http://debian.lcs.mit.edu/debian/ unstable/main amd64 Packages
 *** 1.0.23-2.1 0
        500 http://debian.lcs.mit.edu/debian/ squeeze/main amd64 Packages
        100 /var/lib/dpkg/status

The immediate solution is to remove libasound2 with apt-get purge libasound2 and make sure there are no testing sources listed. The post did not list any, but apt-cache would not show information about sources that were not listed, assuming the cache is up to date. So also run apt-get update to make sure the cache is up to date. Also, enable security updates for stable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.