Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In Emacs, when I type M-h (mark-paragraph), Emacs selects the paragraph under point plus an extra line (typically right above the paragraph). Is there a way to ask Emacs to just select the paragraph?

Note: I have noticed this behavior under shell-script-mode, but haven't checked if it occurs with other major modes.

share|improve this question

1 Answer 1

It's just how Emacs tells paragraphs apart. I wouldn't argue with it. This way, if you keep pressing M-{, more paragraphs get marked seemlessly. And if you really wanted to shrink by one line, just C-n.

I don't mean to be rude, but having started with Emacs from a Windows background, I wasted a lot of time trying to get it to work exactly how I wanted. CUA, delete-selection, etc, etc. I learned a lot but also wasted a lot of time.

Now I run Emacs with most of that stuff disabled, and I actually find the "Emacs paradigm" works. Most of the time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.