Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed a VMware image of FreeBSD, although when I boot up I get the message: Welcome to DesktopBSD, select from the following options:

http://i.imgur.com/VWahL.gif

The trouble is when selecting options 1 - 4 I get the GUI and am unable to login as root, as its disabled in these modes.

How can I effectively exit and go into console mode, so I can login as root?

share|improve this question

migrated from serverfault.com Sep 1 '11 at 13:27

This question came from our site for system and network administrators.

You can try to switch from GUI to any other vty with Alt+Ctrl+F1. FreeBSD usually have X running on 9th console, so first 8 works in text mode.

share|improve this answer

In an environment where the boot routine did not offer the customary option to boot to console – and where things such as Control-Alt-2 were ineffective …

/etc/ttys

I experimented with making a comment of the line for ttyv8. So for example:

# Virtual terminals
ttyv1   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv2   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv3   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv4   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv5   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv6   "/usr/libexec/getty Pc"         xterm   on  secure
ttyv7   "/usr/libexec/getty Pc"         xterm   on  secure
# ttyv8   "/usr/local/bin/xdm -nodaemon"  xterm   off secure

That did not have the desired effect …


PC-BSD

[gjp4@cces3-gjp4-pc-bsd-ergovista621] ~% cat /etc/rc.conf.pcbsd | grep -i pcdm
  # Enable the pcdm display manager
  pcdm_enable="YES"
[gjp4@cces3-gjp4-pc-bsd-ergovista621] ~% 

– changing the YES to NO was effective.


FreeBSD

If there's a display management line in /etc/rc.conf you can make a comment of it, e.g.

# kdm4_enable="YES"

– or change the YES to NO.

share|improve this answer

The Image shown is the bootloader.

Normally 4 should get you to single user mode.

Another option would bee selecting 6 and then type boot -s

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.