Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We're trying to get a QLogic 42C1831 HBA installed on a system using RHEL 4.8. We've tried the drivers from QLogic for Linux Kernel 2.6.x (which this system is running) and are getting all sorts of errors trying to install them. The drivers to specifically mention that they're for RHEL 5.x, but I was wondering if anyone has gotten this to work?

If you'd like to look at the driver files we're using they're here

share|improve this question
1  
@Jon I'd like to see the errors please –  xenoterracide Sep 13 '10 at 20:57
    
This question is not answerable as it is. You have to add more details: Give us the exact kernel with minor version you are running and the errors generated by the unsuccessful attempt to install the drivers please. –  fschmitt Oct 11 '10 at 12:33
add comment

1 Answer

QLogic drivers for 2.6.18 likely won't mix with the 2.6.9 kernel that RHEL 4.8 uses.

For instance, looking at The QLogic Download Page the oldest kernel that is supported is 2.6.16 (SLES 10 SP2).

Without any additional information like dmesg/lspci/compile errors, your best bet would be to upgrade to RHEL5/6 where the device is supported by your vendors.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.