Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I love XTerm but I would like to enable tabbing (multiple terminals in one window separated by tabs).

The terminal Sakura is based on XTerm and tabbing is enabled.

I can open XTerm in my home directory by executing xterm -e 'cd ~/ && /bin/bash'. However, this doesn't work with Sakura (I replaced xterm by sakura). I also tried sakura -e 'cd ~/' but it doesn't work either.

How can I open a shell in Sakura in my home directory?

share|improve this question

migrated from stackoverflow.com Aug 29 '11 at 16:03

This question came from our site for professional and enthusiast programmers.

Doesn't it have a man page you can refer to? – Henning Makholm Aug 29 '11 at 13:52
The man page is not helpful. It merely states that the flag -e executes a command. – Crowhill Aug 29 '11 at 14:48

Sakura is most certainly not based on xterm. It is in fact yet another VTE terminal. The source claims that the -e option is compatible, but clearly is not (xterm uses a shell, for one thing. Also, it doesn't appear to do the "all arguments" nonsense that sakura's source claims it does and emulates with its -e option).

From looking at the source for how it deals with command line arguments, try this:

sakura -x 'sh -c "cd ~; exec /bin/bash"'
share|improve this answer
Thanks so much for answering my question. I tried your suggestion and it leads to progress. The Sakura terminal I get opens no longer as a blank window but in the root directory. How do go to the home directory? – Crowhill Aug 31 '11 at 0:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.