Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have cloned a VirtualBox machine, which runs Ubuntu 11.04 32-bit as Guest OS.

I now wish to transfer it to a new host machine running Windows Vista 32-bit. I’ve transferred the .vdi file and adjusted the name and memory. However when I boot it, the options to choose the Linux version came up:

  • Ubuntu, with Linux 2.6.38-10-generic
  • Linux 2.6.38-10-generic(recovery mode)
  • Previous Linux versions
  • Memory test.

Once I chose Linux 2.6.38 a black screen just appears with an underscore at the top.

What should I do to get it to run? I don’t have my original machine near me now so I can only work with my .vdi image. My VB is version 4.0.10.

I have tried cloning this VDI and also assigning a new UUID and making a new guest, but I still got the black screen.

share|improve this question
    
Have you tested that the image was cloned and copied without corruption? Also, do you use the same VB version (not an older one)? –  rozcietrzewiacz Aug 26 '11 at 17:37
    
Yes, I am using the same VB version and I have tested the cloned version in my original host and it worked. –  GTyler Aug 26 '11 at 18:27
    
It could be a problem with partition identifiers in grub menu.lst or fstab. Please try to boot from an iso-file of some rescue distribution (e.g. knoppix.net), search for /etc/fstab and /boot/grub/menu.lst and add them to your question. We need also the output of sudo /sbin/blkid command. –  andcoz Aug 26 '11 at 19:35

1 Answer 1

There might be some incompatibility between the two host systems. In the virtual machine configuration, under "System", try modifying options like "IO APIC", "PAE/NX", "VT-x/AMD-V" and "Nested Paging".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.