Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I wanted to upgrade my Intel Core i[357] Integrated Graphics (Arrandale) driver so that DRI would work. But some packages were broken in the middle of the installation.

username@hostname:~$ sudo apt-get install -t squeeze-backports xserver-xorg-core
...
dpkg: regarding .../xserver-xorg-core_2%3a1.10.3-1~bpo60+1_amd64.deb containing xserver-xorg-core:
 xserver-xorg-core breaks xserver-xorg-input-7
  xserver-xorg-input-synaptics provides xserver-xorg-input-7 and is present and installed.
...
dpkg: error processing /var/cache/apt/archives/xserver-xorg-core_2%3a1.10.3-1~bpo60+1_amd64.deb (--unpack):
 installing xserver-xorg-core would break existing software
configured to not write apport reports
...
Errors were encountered while processing:
 /var/cache/apt/archives/xserver-xorg-core_2%3a1.10.3-1~bpo60+1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
username@hostname:~$ sudo apt-get install -t squeeze-backports xserver-xorg-core
...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 xserver-xorg-core : Recommends: libgl1-mesa-dri (>= 7.10.2-4) but 7.7.1-4 is to be installed
                     Breaks: xserver-xorg-input-7
                     Breaks: xserver-xorg-video-6
 xserver-xorg-input-evdev : Depends: xorg-input-abi-7.0
...
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).               
username@hostname:~$ sudo apt-get install -t squeeze-backports xserver-xorg-core libgl1-mesa-dri
...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgl1-mesa-dri : Depends: libdrm-intel1 (>= 2.4.23-3~) but 2.4.21-1~squeeze3 is to be installed
 xserver-xorg-core : Breaks: xserver-xorg-input-7
                     Breaks: xserver-xorg-video-6
 xserver-xorg-input-evdev : Depends: xorg-input-abi-7.0
...
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
  1. How do I clean this up?
  2. How do I get the packages to install?
share|improve this question
    
For #2 see x.debian.net/reference/squeeze-backports.html –  Tom Aug 23 '11 at 11:12
    
And for #1, have you attempted apt-get -f install yet, as the program itself advises? –  Shadur Aug 23 '11 at 11:15
    
Yes- it removes packages I need: –  Tom Aug 23 '11 at 11:23
    
~$ sudo apt-get -f install The following packages will be REMOVED: xserver-xorg-input-all xserver-xorg-input-synaptics xserver-xorg-video-all xserver-xorg-video-nouveau ..Do you want to continue [Y/n]? ..Processing triggers for man-db ... Setting up libdrm-nouveau1a (2.4.26-1~bpo60+1) ... –  Tom Aug 23 '11 at 11:23
    
So then I do username@hostname:~$ sudo apt-get install xserver-xorg-input-all xserver-xorg-input-synaptics xserver-xorg-video-all xserver-xorg-video-nouveau to put those back, and check in synaptics for any that got upgraded and left that way (there was one) and downgrade it there. Does that downgrade leave it pinned? –  Tom Aug 23 '11 at 11:24

2 Answers 2

Here's a generic piece of advice in this kind of situation; I don't know if it'll work in this particular case.

Run aptitude and see what it proposes to resolve the conflicts (press , and . to navigate between the proposed solutions, press g if you find a satisfying one.

share|improve this answer
    
This can also be done in CLI mode with aptitude install -f in his case. Unfortunately, the aptitude dependency resolver doesn't seem to work as well as it used to. –  jordanm Oct 11 '12 at 1:22

These two lines are the problem:

xserver-xorg-core : Recommends: libgl1-mesa-dri (>= 7.10.2-4) \
    but 7.7.1-4 is to be installed
libgl1-mesa-dri (>= 7.10.2-4) but 7.7.1-4 is to be installed

As far as I can tell, basically your backports repos for the x..-video* drivers want a newer version of xserver-xorg-core and its dependencies than whatever repo you've pulled it from. Does the backports repo offer that package as well? If so, you might want to update the whole xserver from the same repository.

Either that or I've got it backwards and the backports stuff is too old for your current kit and vice-versa - but you'll probably want to singly source the whole metapackage in any case.

Sorry if that's too vague - I don't Debian much.

I suppose a different solution might be had by just manually overriding dependencies and choosing the newer version of all packages available - but that would require you to cross your fingers at the very least, which isn't always a sure thing either, I've found.

Looking a little closer and just a little ways up there's:

dpkg: error processing \
    /var/cache/apt/archives/xserver-xorg-core_2%3a1.10.3-1~bpo60+1_amd64.deb \
(--unpack): installing xserver-xorg-core would break existing software

You should at least clear the package cache. Your package manager appears to be trying to install an older version of xserver-xorg-core to handle the driver updates from your local package cache directory on disk - it should probably be downloading a new version of that. It might not be doing so on its own due to the input package listed before that or maybe just because you need to update your repo lists first, or maybe because you need to add another repo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.