Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used dd to clone a x4100 server with Linux Red Hat. The hardware is identical for old and new servers. Disks are sda, sdb and sdc(sdc1 and sdc2). But newly restored server gives following errors and Linux can only be started in maintenance mode (read-only):

Red Hat nash version is starting:
shpchp: shpc_init: cannot reserve MMIO region.
shpchp: shpc_init: cannot reserve MMIO region.
shpchp: shpc_init: cannot reserve MMIO region.
shpchp: shpc_init: cannot reserve MMIO region.
Reading all physical volumes. This may take a while
(...)
/boot: ext3 recovery flag is clear but journal has data.
/boot: Run journal anyway    
/boot: Unexpected inconsistency RUN fsck manually.

What might be the reason? Did I miss something during backup/restore? How can I fix the new system?

share|improve this question

migrated from stackoverflow.com Aug 22 '11 at 12:50

This question came from our site for professional and enthusiast programmers.

1  
Can you provide the dd commands you used to both copy the original disk and transfer it to the new one? –  Manny D Aug 22 '11 at 12:40
    
dd if=/dev/sdc | gzip | ssh root@backupserver dd of=/root/sdc.gz (backup) dd if=sdc.gz | ssh root@newserver "gunzip -c | dd of=/dev/sdc" (restore) I used to RIP cd to set up ssh connection on the new server. –  Ephieste Aug 22 '11 at 12:43
2  
A stupid question: have you executed the backup command running the system from a live CD, or anyway with all sdc partitions unmounted? –  enzotib Aug 22 '11 at 12:55
    
I unmounted the partitions manually but not tried to use live cd? might there be a problem during unmount? Should I use also RIP or knopix to run backup? –  Ephieste Aug 22 '11 at 13:17
5  
Have you tried running fsck manually? Something like fsck -C -y /boot –  MaxMackie Aug 22 '11 at 14:13
show 3 more comments

2 Answers

You didn't dd the drive while it was mounted did you? If you're doing to use this mechanism for duplicating a disk, boot into a rescue OS (e.g. from a CD or USB drive) so that you unmount your FS before copying it.

Or, in a pinch, you can cheat by using the magic sysrq to remount all drives readonly, but that has consequences.

share|improve this answer
add comment

Can you check if you are able to boot from the grub into single user mode? Try Linux rescue mode and see if you can fsck all the partitions.

Also, please try updating the initrd file, since the hardware is changed. Goto single user mode/rescue mode from grub and in shell, mount the root filesystem and execute the following

# cp /boot/initrd-2.6.16-1.2129_FC5.img /boot/initrd-2.6.16-1.2129_FC5.img-original
# mkinitrd -fv --preload=ehci-hcd --preload=usb-storage --preload=scsi_mod --preload=sd_mod /boot/initrd-2.6.16-1.2129_FC5.img 2.6.16-1.2129_FC5

Also update the grub configuration file (menu.lst or grub.conf) and make sure the correct file is referenced in the boot stanzas.

share|improve this answer
    
It has been noticed that in some versions of mkinitrd, the iscsi related drivers are not updated to detect multipath io scsi configuration, though. So, download and install the correct/updated version of mkinitrd compatible with the kernel version and run the command, incase the existing mkintrd does not resolve the case. I was trolling through some of the links and found this errata on RHN rhn.redhat.com/errata/RHBA-2009-0237.html, if it helps. –  Nikhil Mulley Nov 30 '11 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.