Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
max@linux-vwzy:~> vlc --version
VLC media player 1.1.11 The Luggage (revision exported)
VLC version 1.1.11 The Luggage (exported)
Compiled by abuild on messiah (Aug 17 2011 15:23:16)
Compiler: gcc version 4.5.1 20101208 [gcc-4_5-branch revision 167585] (SUSE Linux) 
This program comes with NO WARRANTY, to the extent permitted by law.
You may redistribute it under the terms of the GNU General Public License;
see the file named COPYING for details.
Written by the VideoLAN team; see the AUTHORS file.

Every file I seem to play requires me to bring the audio back about 0.4 of a second. I would post if this was for a couple video, but this is my entire video library which was encoded in different ways and created at different times. This only seemed to happen when I switched my window manager from KDE to dwm; it worked fine in vlc before that

share|improve this question
    
@froztbyte This only seemed to happen when I switched my window manager from KDE to dwm. Added to question –  maxmackie Aug 22 '11 at 11:02
    
What format are you playing and what the cpu use when playing them? When you have high cpu use the video will get behind the audio. I have had this issue on hd quicktime files and h.264 form my sony dlsr. –  saras Sep 5 '11 at 11:30
    
So are you using a sound server now (PulseAudio or other)? –  Gilles Sep 8 '11 at 23:22
    
@saras, Every format you can imagine –  maxmackie Sep 8 '11 at 23:36
    
@Gilles, Is there a way for me to verify? I haven't messed with the default KDE audio options –  maxmackie Sep 8 '11 at 23:36

1 Answer 1

You didn't indicate if you tested this on another application as well, so the problem might be the sound server you're using. If you're using PulseAudio, it does introduce delays which might be the cause of your problem. Without more info, it isn't really possible to say.

share|improve this answer
    
This only seemed to happenw when I switched window manager from KDE to dwm. It worked fine in vlc before that –  maxmackie Aug 22 '11 at 11:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.