Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Today I installed Fedora 15 in a VBox VM to try out Gnome 3. After installing the guest extensions almost everything works fine. Except for the slow response time in fullscreen mode (HOST+F).

By that I mean textareas responding only after I've typed whole words, window dragging won't register etc.

However in maximized window mode everything runs smoothly.

Anyone have a similar experience? What can I do?

VirtualBox guest settings are as following.

  • 1,5 GB RAM
  • 1 CPU core (no limitations, 2,2Ghz host)
  • 128 MB video memory
    • 3d accel enabled
    • 2d accel disabled (it says this is only for windows guests)
  • rest is defaults

I also have a graphics card that uses nvidia's optimus technology but I doubt that this is the problem.

Host OS is Windows 7 Professional

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

You can solve this problem by right clicking on the VirtualBox menu item and selecting the "Run with nvidia graphics" option. I'm not exactly sure what it's called in the English version of Windows because I'm using a different language.

I have Optimus as well and I've had the same problem as you when I ran it with the Intel graphics. It appears to be a problem with the Optimus technology afterall.

share|improve this answer
    
That solution is not helpful if battery life is important. I'd be perfectly happy with a disabled nvidia processor in the VM, if not for the issues with the intel. –  user37906 Apr 26 '13 at 9:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.