Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Fedora 15 and Transmission BT client. Transmission can't open ports unless the firewall is disabled.

I searched some posts that said add 1900 to the trusted ports, or via a iptable rule: -A INPUT -m state --state NEW -m udp -p udp --sport 1900 -j ACCEPT". However, Transmission can't open ports anyway.

I also tested with upnp-inspector, which is better than Transmission, it could detect my upnp router after add 1900 to the trusted ports, but the detection is slower than if the firewall is disabled.

Any ideas on how to let Transmission UPnP works with the Firewall?

share|improve this question
add comment

1 Answer

I found a slightly secure method than disable the firewall, which is allow port range from 10000 to 59999. And you don't need to open 1900.

share|improve this answer
    
Yes, Its just slightly better... The main issue is even if you open ports on the router, Iptables will block that port at your localhost. I have strong Iptables rules, then port forwards for my specific apps. Then I disable UPNP, and then I get the benefit of the firewall. –  TechZilla Jan 18 '12 at 12:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.