Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed Katya (linux mint 11) on my new Dell Inspiron 15R, and in Windows, my mouse supports multitouch (two finger scroll, three finger swipe, etc.). I have checked Preferences->Mouse and there is supposed to be a Touchpad, or similar section, but there is no such section available. Sidescrolling works, but I am unable to find any trackpad/touchpad specific settings. Anyone have a solution?

EDIT: for clarification, i am dual booting Win7 and Mint in separate partitions on the same machine.

share|improve this question
1  
What is the trackpad manufacture? Synaptics? Alps? Have you installed specific xorg-input drivers for that manufacture? –  Caleb Aug 17 '11 at 22:20
    
Alps Electric, according to Windows Device Manager. Here might be the problem; the Device Manager reads that the touchpad is plugged into the PS2 mouse port. If Mint reads it the same way, this might explain why it thinks it's an external mouse... –  jlehenbauer Aug 17 '11 at 23:55
add comment

1 Answer 1

As far as I know the multitouch support and other touchpad specific input device features on Linux only work on USB, not PS2.

The touchpads in most new laptops are USB, but often the BIOS has an emulator mode to present the device as PS2 for compatibility with older OSes. You should look through your BIOS and turn off anything to do with emulating PS2 devices. Chances are when you boot up with the touchpad showing up as a USB device Linux will figure out what it is and give you some features for it.

share|improve this answer
    
i looked through the BIOS and couldn't find any option for PS2 vs. USB touchpad emulcation. Is there a way i could force Linux to think it's a USB device? –  jlehenbauer Aug 18 '11 at 18:08
    
Only if it actually IS a USB device. Can you confirm that from the model / specs of your machine? –  Caleb Aug 18 '11 at 18:50
    
i found this for disabling the Alps touchpad, and they had the similar issue with no trackpad option in the mouse menu. But no options for two finger scrolling... and i found this article for scrolling on a latitude, but i'm not sure if this is the similar enough.. –  jlehenbauer Aug 18 '11 at 20:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.