Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
  • I am trying to install Ubuntu 10.04 on my machine which already has Windows Vista and Fedora installed.

  • I use GRUB to get the boot menu. The GRUB screen looks something like this (has a fedora logo at the bottom)

    alt text

  • The problem is that when I insert the CD and try to boot, it takes me directly to the GRUB menu for Fedora/Vista, nothing for Ubuntu.

  • So, I tried Ubuntu's CD boot helper to help me boot from the CD, and I get this error

    alt text

  • The BIOS says that I should press F2 for setup and F12 for boot options. I tried them. Nothing happens except that it goes straight to the GRUB menu.

What should I do?

Originally posted here, did not get a solution till now.

share|improve this question
add comment

3 Answers

The Ubuntu Boot CD Helper can't write to the MBR of the disk. Though I have never used it, I can assume this is because you don't have a Windows bootloader installed there, you have grub.

Chances are that you are using a usb keyboard (please do specify) and USB Legacy Support is not enabled in your mobo. This renders it unusable until the OS loads the appropriate drivers for the USB ports. A 'quick' way to work around this is to plug in a ps2 keyboard (if you have one).

Alternatively, you can set grub to boot from the cdrom drive.

Boot into Fedora,

~# sudo vi /boot/grub/menu.lst

And following from the last line, add

title CDROM

root (hd0,0) (this will be subject to your schema, you will need to place the appropriate device name here)

kernel /boot/grub/memdisk.bin

initrd /boot/grub/sbootmgr.dsk

See if that works.

Another alternative would be to restore the boot sector from windows and then use the Ubuntu CD Boot Helper.

Haven't done it myself on Windows7, but if I recall corretly, it involved running

fixmbr fixboot

This will, of course, reset your boot sector to a state where you can only boot windows. But upon being able to install Ubuntu, you will be able to add an entry for Fedora too.

Cheers!

(And apologies about the poor formatting, I am still looking into it).

share|improve this answer
    
thanks, I'll try this out and get back. Also, the machine is a laptop, so it is not a USB keyboard. –  Lazer Sep 11 '10 at 17:19
    
@Lazer - Got a make and model ? Maybe there's a BIOS specific setting affecting it. –  wormintrude Sep 11 '10 at 22:10
add comment

You should be able to just modify your BIOS boot order settings to make the BIOS check the CD-ROM drive before the hard disk. It's that simple, usually.

share|improve this answer
add comment
up vote 1 down vote accepted

It was a stupid problem.

My machine has function keys that need to be pressed in combination of Fn key (opposite to what is there in most laptops). So, I was trying just that (Fn+F2, Fn+F12).

Turns out while booting, you need to press F2 without the Fn key.

share|improve this answer
1  
You need to mark this question as answered, ie accept your own answer. Or delete it altogether. –  Neil Mayhew Sep 12 '10 at 23:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.