Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

NetworkManager on Fedora14 doesn't support the "--float" parameter of OpenVPN client.

Are there any workarounds to connect with NetworkManager to an OpenVPN network using the --float option?

Or are there any other graphical Network Managers for GNOME that would have this feature?

share|improve this question
2  
a quick search for "network manager openvpn float" reveals that someone patched ubuntu's network manager to support it. Dont know if it made it to upstream, and no luck onadding fedora. Look for nm-openvpn-service binary on your installation a execute a strings "strings /path/to/nm-openvpn-service" and grep for this option. If it is not there, is not supported :S. You could also try to hack it up crafting the patch made for ubuntu. –  Torian Aug 16 '11 at 12:24

1 Answer 1

up vote 1 down vote accepted

If I were faced with this I would:

 mv /usr/sbin/openvpn /usr/sbin/openvpn.binary
 echo "#!/bin/sh
exec /usr/sbin/openvpn.binary --float $*" >/usr/sbin/openvpn
 chmod 755 /usr/sbin/openvpn

and then see if the existing tools still work. It should cause it to pass --float all the time. You can add code to your new 'openvpn.sh' script if you only want to pass it for certain connections (maybe echo $* | grep client.conf).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.