Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Firefox and Google Chrome under Ubuntu 10.04, and get these warnings:

firefox

chrome

I want to add the site's certificate to "somewhere", so that the browser doesn't show SSL cert errors when visiting that given site.

p.s.: a command-line solution would be the best.

share|improve this question
    
What you want is to completely disable ssl features? Looks foolish, please explain your motivations in your question, if any. –  Stéphane Gimenez Aug 11 '11 at 11:26
    
sorry if i wasn't clear enough, I just want to add a site's certificate to "somewhere", so that the browser doesn't shows SSL cert error when visiting that given site. –  LanceBaynes Aug 11 '11 at 11:39
1  
You can press the "Confirm security exception" to disable it for that one cert. Disabling it everywhere defeats the purpose of SSL. A certificate means "someone I turst says you are who you say you are". If you accept bad certs globally you basically say "I belive everything you tell me". Just like with plain HTTP. –  stribika Aug 11 '11 at 18:00
1  
In theory, this message is telling you that someone has hijacked your Internet connection or replaced the site by a decoy. In practice, this message is telling you that the site you're visiting is misconfigured. –  Gilles Aug 11 '11 at 23:32
add comment

3 Answers

up vote 1 down vote accepted

The reason that the Permanently store this exception checkbox in Firefox is disabled is because you're in private browsing mode, or your security settings in Firefox are set to never remember history.

Set it to remember history, reload the page then permanently store it. After this you can change back to never remember.

I don't know if Chrome has a way to do that though.

share|improve this answer
add comment

Non command-line solution

In the "Add Security Exception" window that appear for a specific site, push "get certificate", check "permanently store this exception" and push "Confirm security exception".

share|improve this answer
    
As I attached a printscreen, I CAN'T check the box: "permanently store this exception". –  LanceBaynes Aug 11 '11 at 11:51
3  
Ah right, in your case the domain name provided in the certificate is wrong. I fear that most browsers will not provide a way to suppress the warning in that case. –  Stéphane Gimenez Aug 11 '11 at 12:08
    
I will try to put a self-signed cert to this domain then..okay –  LanceBaynes Aug 12 '11 at 5:31
add comment

Does the site in question have a root certificate that you can download?

http://tldp.org/HOWTO/SSL-Certificates-HOWTO/x175.html

http://tldp.org/HOWTO/SSL-Certificates-HOWTO/

share|improve this answer
    
ehh, how can I check that? can you pls tell me? –  LanceBaynes Aug 12 '11 at 5:41
    
you would have to look on the website. i had the same problem with the website of my uni. all subsites created their own certificates but once you trust the root all derived are trusted too. They had an extra tutorial for this to help the non it-students. The file was called <domainname>.der (i think) –  unR Aug 12 '11 at 7:47
    
:\ I'm not sure i could find the root cert:\ but TY! –  LanceBaynes Aug 12 '11 at 7:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.