Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm new to KVM. I use the following way to create and start a guest KVM machine.

qemu-img create -f raw centos.img 100G
/usr/libexec/qemu-kvm -hda ./centos.img -cdrom /usr/local/CentOS_5.6_Final.iso -m 1024 -smp 1 -boot d
/usr/libexec/qemu-kvm -hda ./centos.img -m 1024 -smp 1 -boot c

When the login page appears, everything seems right.

enter image description here

When I log into the system, it show me like this. Note the following image shows what I saw when I just log into the system, without move my mouse or press a key. enter image description here

Take a closer look. enter image description here

When I click the left mouse button, it shows me this menu. enter image description here

Anyone can help me with my problem? How to fix the graphics in the guest machine?

Thanks in advance.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

It looks like you've installed X, but haven't installed any desktop environments (Gnome, KDE, XFCE, LXDE, etc), so you're getting the minimal bundled window manager.

share|improve this answer
1  
Yep, it's twm: xwinman.org/vtwm.php –  rvs Aug 10 '11 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.