Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have done a few installs of openSUSE to use as a Xen dom0 and have not got it working yet. These are the steps I followed:

  1. Installed openSUSE 11.4 from Live KDE CD.
  2. Installed all updates via YaST>Package Management.
  3. Installed Xen via YaST>Install Hypervisor (installed all xen and kernel packages required).
  4. Reboot into Xen kernel.

After this if I go into YaST>Create Virtual Machine I can specify all the relevant options for my first VM (domU) but when I click finish I get this error:

Failed to start vm-install

If I then go into YaST>Virtual machine Manager then right click the Xen Hypervisor and click Connect I get the following errors:

Unable to open a connection to the Xen hypervisor/daemon.

Verify that:
- A Xen host kernel was booted
- The Xen service has been started

and

unable to connect to 'localhost:8000': Connection refused

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/connection.py", line 983, in _try_open
None], flags)
File "/usr/lib64/python2.7/site-packages/libvirt.py", line 107, in openAuth
if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: unable to connect to 'localhost:8000': Connection refused

I am definitely in the correct Kernel and all processes appear to be started as per:

kaon:/home/danny # uname -a
Linux kaon.cybertron.local 2.6.37.6-0.7-xen #1 SMP 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux
kaon:/home/danny # ps -ef | grep xen
root 15 2 0 19:54 ? 00:00:00 [xenwatch]
root 16 2 0 19:54 ? 00:00:00 [xenbus]
root 1735 1 0 19:55 ? 00:00:00 xenstored
root 1742 1 0 19:55 ? 00:00:00 xenconsoled --pid-file=/var/run/xenconsoled.pid
root 2017 1 0 19:55 ? 00:00:00 /usr/bin/python /usr/sbin/xend start
root 2019 2017 0 19:55 ? 00:00:00 /usr/bin/python /usr/sbin/xend start
root 2975 2956 0 20:00 pts/1 00:00:00 grep xen

I have posted this issue on the openSUSE forums here but no one has been able to help.

The only other thing I've found Google searching that relates to this error is a mismatch between the versions of xen and xen-tools installed which I have confirmed is not my case, both packages have matching versions as expected.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
chkconfig xencommons off
reboot
share|improve this answer
    
What is xencommons (a service - but what does it do badly)? –  Nils Oct 8 '11 at 21:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.