Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I Have a RHEL 6.1 server and it's date/time changes automatically even after I change the time settings.

Could someone point out how to fix this issue?

Note** I suspect this happens when rhn updates are carried out. But I don't know where to set time zones for rhn.

Thanks,
Shamal

share|improve this question
    
How do you "change the time settings"? –  Mat Aug 10 '11 at 5:30

1 Answer 1

up vote 3 down vote accepted

During initial setup, RHEL asks you to pick your time zone and provide the address of an NTP server. I suspect that your time zone is set wrong, and it is periodically "fixing" your time changes to match what the NTP server says. It is also possible that you gave the IP of an NTP server that itself is not reliably on the right time.

To check this, run system-config-date as root.

If the settings there look fine, try:

$ ntpdate -q pool.ntp.org

If your time setup is correct, you should get several answers with an "offset" value well under 1 second, and the last line should give correct local time. Substitute the time server you used for pool.ntp.org above if you changed it during setup, to ensure that that server is working correctly.

If you need this system to always obey the hardware RTC and never do NTP network time synchronization, you can disable ntpd by saying:

# service ntpd stop
# chkconfig --del ntpd
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.