Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have openSUSE 11.4 installed on my HP pavilion dm4-2015dx. The ethernet card (Attansic ethernet controler is shown in Yast's hardware info) was not recognized and after many days of googleing i found similar problem that has been solved. I tried to do what is described on ubuntu forum but it didn't work for me. Although I finally have eth0 - but connection cant be established.

Next thing I tried to enable Tumbleweed repository and update to kernel 3.0 (which could have drivers). Short after updating kernel I had two eth devices, but only one was activated when plugged in LAN cable. Still couldn't connect.

After rebooting there is only one eth device - but not sure which one.

How can I "uninstall" drivers from ubuntu forum? Or did Kernel override them?

Any other suggestion on how to solve my problem is more than welcome!


share|improve this question
up vote 1 down vote accepted

After couple of updates I'm able to connect with ethernet card!

It seems that Kernel 3.0. solved that issue after all... Or maybe 3.0.1.

You just need to be persistent :)

share|improve this answer

I had the same problem. In my case, it was CentOS and eth0 did not show up on ifconfig. I tackled the issue by downloading the appropriate RPM package from elrepo.org.

I need alx ethernet driver for Atheros AR8161 ethernet Controller. So downloaded kmod-alx-0.0-2.20121003.el6.elrepo.x86_64.rpm.

Then executed, rpm -ivh packagename

It worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.