Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Reading the Virtualbox user manual, I finally got [here], which explains how to install Virtualbox Guest Additions on a Linux guest via Command Line.

But it's not clear enough for me (I just started learning some commands). Can someone put down the exact commands you would use to install Virtualbox Guest Additions via CLI? (which includes finding where virtualbox guest additions has been mounted etc.)

share|improve this question

5 Answers 5

up vote 34 down vote accepted

... finally this worked for me, should also work for anybody else trying to install Virtualbox Guest Additions on a CentOS (x86_64) virtual server in command line mode.

# yum update
# yum install gcc
# yum install kernel-devel
# yum install bzip2
# mount /dev/scd0 /media/cdrom
# sh /media/cdrom/VBoxLinuxAdditions.run

When the process is complete, reboot the system. That's all.

share|improve this answer
1  
I do not think there is a need for the reboot here. Just check the vbox* modules are installed under /lib and then run modprobe for each vbox module; make sure the vbox startup scripts at /etc/init.d/vbox* are all (re)started. To just check whether the VBoxAdditions are working, I would start with testing the copy-paste between the source and vmguest. Run VBoxClient-all command and see if it returns anything. If nothing is returned VBox is setup fine. Also, check chkconfig to make sure the vbox startup scripts are properly defined to start at required runlevels. –  Nikhil Mulley Nov 30 '11 at 10:24
1  
You need to yum install make as well –  nic ferrier Feb 6 '12 at 12:23
2  
I try to do the line mount /dev/scd0 /media/cdrom and I get: mount point /media/cdrom does not exist. Is there something I am missing? –  theJerm Oct 31 '12 at 18:46
5  
@theJerm I hope you already figured this out, but for the record: create the mountpoint (just a directory) with sudo mkdir /media/cdrom. –  Anthon Jun 10 '13 at 20:27
2  
On a minimal install of CentOS 6.4 64b the install command was sh /media/cdrom/VBoxLinuxAdditions.run. I also had to install Perl (yum install perl) and create the mount-point (sudo mkdir -p /media/cdrom). –  smholloway Nov 11 '13 at 16:18

This is an old thread but came up in my search for a similar issue. In case anyone else runs into this, the following answer solved it for me:

http://www.if-not-true-then-false.com/2010/install-virtualbox-guest-additions-on-fedora-centos-red-hat-rhel/

Note* The URL says 2010 but the article was updated in 2013.

share|improve this answer
1  
These steps are a lot better, because they include all of the necessary prerequisites like perl and dkms –  bmaupin Sep 26 '14 at 16:07

After installing the VBOXADDITIONS you might need to do this:

In VirtualBox click View>>Auto Resize Guest Display (Host + G)

because the screen resolution did not work for me until I applied this final configuration to VirtualBox.

share|improve this answer

@its_me's answer almost worked, but it failed building some kernel modules.

If it doesn't work for you, look at the messages.

In my case, one of them asked to look into /var/log/vboxadd-install.log. There it said something about missing kernel sources and to provide the kernel source directory with e.g. KERN_DIR=/path/to/kernel/sources.

Since kernel-devel and sources at /usr/src/kernels/2.6.32-504.16.2.el6.x86_64 were already installed, I was confused, but called it with the requested environment variable

KERN_DIR=/usr/src/kernels/2.6.32-504.16.2.el6.x86_64 sh /media/cdrom/VBoxLinuxAdditions.run

Now it complained about missing header files and suggested to do

yum install kernel-devel-2.6.32-504.el6.x86_64

As you can see, this is a slightly different version, 504.16.2 vs just 504. After installing the proper kernel-devel package, building and then installing worked as expected.


So, running kernel and installed kernel sources (aka kernel-devel) must match. You can verify this by looking at the running kernel with

uname -a

and the installed sources at

ls /usr/src/kernels

As a final conclusion, whatever happens, look at the messages and log files provided.

share|improve this answer

Just a little detail ... I had a CentOS 6.6 minimal, did all the "yum update" and "yum install" but I was still stuck until I've read this in Olaf's response

... this is a slightly different version, 504.16.2 vs just 504. After installing the proper kernel-devel package, building and then installing worked as expected.

So, running kernel and installed kernel sources (aka kernel-devel) must match.

checking on my install I had the same problem, after doing a reboot, everything was ok. The machine was still running with the old kernel. After this the next problem as that perl was missing so I had to do also an

yum install perl
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.