Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So I am trying to get X to start on my second (PCI 02.00:00) video card and stop using the main card (PCI 1.00:00). I would like to do this because I want to pass through the PCI 1 card to a XEN HVM VM and use the second card as the main display for the dom0. I am led to believe that only the the first card on the PCI bus is compatible with XEM PCI VGA Pass thou.

I'm using CentOS 6 with XEN 4.1; standard X with VESA drivers for now. Both cards are NVIDIA GeForce 8400 series.

I have played around with custom xorg.conf by commenting out the references to the first device and screen, but that does not seem to work. I am also familiar with the PCIBACK module and can get the first video card to show up correctly in the xm pci-list-assignable-devices command.

share|improve this question
    
Good luck. I couldn't run the ATI drivers on a Xen kernel with CentOS either... maybe nVidia did it right. –  Aaron D. Marasco Aug 9 '11 at 1:27
add comment

1 Answer

You can force an X video driver to use a specific card by adding a line to its device section of xorg.conf called Option "BusId" "x" where x is the PCI bus ID you gave. The format would be something like this. If you don't have any xorg.conf at all adding just these lines to a new file:

Section "Device"
    Identifier      "nvidia"
    Driver          "nvidia"
    BusId           "PCI:2:0:0"
EndSection
share|improve this answer
    
Thanks Caleb, That is what the xorg.conf looks like minus the BusID part. Looks like it makes total sense. I will try when I get home today and see what happens. –  Jim DeVito Aug 10 '11 at 12:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.