Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've currently got Fedora 9 on my home PC (yes, I know its quite old - but hell I only reboot it every 6 months - nevermind upgrading!) . My only niggle is that keyboard I've got has quite a different feel / lyaout to the one I use everyday in work. To make life a bit simpler, I tried to enable the audio feedback. I first tried the setting in KDE (4.2) System settings - to no avail. I also tried 'xset c 100' but still nothing. The ALSA inerface seems to have no problems producing audio output from mplayer, xine, amarok.... and kmixer works as expected.

Looking at the Xorg man pages there's nothing obviously jumping out here. Any ideas?

share|improve this question
2  
'xset c on' doesn't fix it I assume? –  polynomial Aug 30 '11 at 19:56

1 Answer 1

up vote 1 down vote accepted

X11's keyclick setting is primarily meant for the keyboard's on-board speaker. Many workstations without audio devices had keyboards with a speaker and simple audio device on-board. It played the keyboard bell noise (hence the name), and also clicked. The keyboards could be instructed to turn keyclick on or off, and some even had volume settings. Sun Type 3/4/5 keyboards certainly did this (even on Sun workstations with audio). I can't speak about others.

PC keyboards don't have sound capability, and it's almost certain the X PC keyboard driver doesn't use the PC speaker device for this. xset c has never worked for me for as long as I've used X11 on PCs (since the days of Linux 0.99).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.