Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

X won't start on my main machine. I can start it as root, but then it only logs me in as root -- I can't use my regular user account. When I start up, it flashes a black screen, then hangs at "Stopping userspace bootsplash".

What can I do to fix this? I'm running Ubuntu 11.04 x64.

Edit: My Xorg.0.log is here

share|improve this question
    
Can you get into safe/recovery mode during start-up? That offers some options to fix X. –  Tim Aug 7 '11 at 17:17
    
Yes. I tried that. But I don't know what to do. –  iAndr0idOs Aug 7 '11 at 17:20
add comment

2 Answers

I fixed the problem. Turns out, my language setting for my user was messed up, so I fixed it in root, and it started working perfectly fine again.

share|improve this answer
add comment

If it does work for root, then I would look if your /home/ is not full. Try:

df -h 

If it's full, make some space. As a workaround you can create a new user from console:

root@box# useradd -m another

setup a password:

root@box# passwd another

and retry.

Another workaround worth to try is to reset your gnome settings in case you messed them up somehow:

cd ~you
mv .compiz .compiz_old
mv .config .config_old
mv .gconf .gconf_old
mv .gnome2 .gnome2_old
mv .local .local_old

and try to relogin.

share|improve this answer
    
Filesystem Size Used Avail Use% Mounted on /dev/sda5 119G 96G 17G 86% / none 1.9G 704K 1.9G 1% /dev none 1.9G 168K 1.9G 1% /dev/shm none 1.9G 388K 1.9G 1% /var/run none 1.9G 0 1.9G 0% /var/lock –  iAndr0idOs Aug 7 '11 at 18:48
    
And that didn't work... –  iAndr0idOs Aug 7 '11 at 19:03
    
I fixed it. Thanks for your effort, though. –  iAndr0idOs Aug 7 '11 at 19:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.