Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Netgear WNA1100 Wireless Adapter that I bought a few weeks ago, so its fairly new. Last night it was working perfectly. I turned my computer off for the night, came back in the morning, and found that I had no wireless. The desktop that its being used on is running is Fedora 15 x32 and my laptop where I did testing on runs Fedora 15 x64

dmesg output

[63046.973098] usb 2-1.2: new high speed USB device number 12 using ehci_hcd
[63047.079092] usb 2-1.2: New USB device found, idVendor=0846, idProduct=9030
[63047.079103] usb 2-1.2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[63047.079109] usb 2-1.2: Product: WNA1100
[63047.079114] usb 2-1.2: Manufacturer: NETGEAR WNA
[63047.079118] usb 2-1.2: SerialNumber: 12345
[63047.385150] usb 2-1.2: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[63047.619805] ath9k_htc 2-1.2:1.0: ath9k_htc: HTC initialized with 33 credits
[63047.811373] ath9k_htc 2-1.2:1.0: ath9k_htc: FW Version: 1.0
[63047.811382] ath9k_htc 2-1.2:1.0: ath9k_htc: Please upgrade to FW version 1.3
[63047.812138] Failed to initialize the device
[63047.821250] ath9k_htc: probe of 2-1.2:1.0 failed with error -22

Ok, that's not good but isn't helpful as Google can't seem to find anything on error -22. So I bring up a Windows XP VM in Virtualbox, install the Netgear software, and get a Code 10 error in the driver manager. Possible causes as listed on their website for this error

  • IRQ conflict
  • Adapter not plugged in properly
  • Wrong/Incorrect driver installed

Well I'm sure its plugged in properly (wasn't touched on my desktop) and I'm sure I have the right driver, which leaves the IRQ conflict, which makes absoltely no sense.

As a side note when testing in Virtualbox I got a big wall of errors in dmesg. They are all pretty much

[62656.644660] WARNING: at net/ipv4/route.c:1677 ip_rt_bug+0x5c/0x62()
[62656.644667] Hardware name: 4298CTO
[62656.644671] Modules linked in: ath9k_htc ath9k_common ath9k_hw ath tcp_lp fuse vboxpci vboxnetadp vboxnetflt vboxdrv 8021q garp stp llc cpufreq_ondemand acpi_cpufreq freq_table mperf rfcomm bnep coretemp snd_hda_codec_hdmi snd_hda_codec_conexant arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm btusb bluetooth thinkpad_acpi snd_timer snd iwlagn mac80211 cfg80211 soundcore iTCO_wdt snd_page_alloc rfkill iTCO_vendor_support i2c_i801 microcode joydev wacom e1000e sdhci_pci sdhci mmc_core wmi uas usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
[62656.644807] Pid: 18137, comm: VirtualBox Tainted: G        W   2.6.40-4.fc15.x86_64 #1
[62656.644814] Call Trace:
[62656.644832]  [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
[62656.644845]  [<ffffffff81054cc0>] warn_slowpath_null+0x1a/0x1c
[62656.644856]  [<ffffffff81400f9f>] ip_rt_bug+0x5c/0x62
[62656.644867]  [<ffffffff81407c0b>] dst_output+0x14/0x16
[62656.644877]  [<ffffffff8140946b>] ip_local_out+0x20/0x25
[62656.644885]  [<ffffffff8140a307>] ip_send_skb+0x19/0x58
[62656.644899]  [<ffffffff81425b6c>] udp_send_skb+0x239/0x29b
[62656.644911]  [<ffffffff81427093>] udp_sendmsg+0x559/0x78c
[62656.644924]  [<ffffffff811f4e3a>] ? avc_has_perm_flags+0x61/0x7a
[62656.644937]  [<ffffffff81407d7e>] ? ip_select_ident+0x3d/0x3d
[62656.644950]  [<ffffffff8142d93e>] inet_sendmsg+0x66/0x6f
[62656.644961]  [<ffffffff813c975d>] sock_sendmsg+0xe6/0x109
[62656.644974]  [<ffffffff8105a6e4>] ? _local_bh_enable_ip+0x25/0x8e
[62656.644985]  [<ffffffff8140be11>] ? do_ip_setsockopt+0xaa1/0xada
[62656.645005]  [<ffffffff81041325>] ? should_resched+0xe/0x2d
[62656.645018]  [<ffffffff813c7fee>] ? might_fault+0x21/0x23
[62656.645029]  [<ffffffff813c801f>] ? copy_from_user+0x2f/0x31
[62656.645039]  [<ffffffff813cb253>] sys_sendto+0x12f/0x171
[62656.645049]  [<ffffffff8140bf1b>] ? ip_setsockopt+0x2d/0x8d
[62656.645061]  [<ffffffff8112f5e8>] ? path_put+0x20/0x24
[62656.645073]  [<ffffffff810a0c7c>] ? audit_syscall_entry+0x145/0x171
[62656.645086]  [<ffffffff814bd7c2>] system_call_fastpath+0x16/0x1b
[62656.645094] ---[ end trace af0b7ceb6aa2690a ]---
[62657.392996] ip_rt_bug: ->, ?

What could possibly be the problem? This was working just fine last night. I've tried every usb port on two different computers, all with the same message. How can something just die over night

share|improve this question
How did you install the .fw file in fedora 15? – user9750 Aug 10 '11 at 11:14
@Mali I originally just used the linux-firmware package. But to fix it I downloaded the firmware from here wireless.kernel.org/download/htc_fw/1.3/htc_9271.fw and replaced the file with the same name in /lib/firmware – TheLQ Aug 10 '11 at 14:07
up vote 3 down vote accepted

The output of dmesg indicates clearly:

[63047.811382] ath9k_htc 2-1.2:1.0: ath9k_htc: Please upgrade to FW version 1.3

-- you have a problem with firmware. You should rebuild the firmware blob and the kernel module.

I don't use Fedora, so I can't give you the exact commands. You must refer to the manuals (or forums) for your distribution-specific package management tools. But the general procedure you should follow would be to

  1. Find out to which package "ath9k_htc" belongs - if it's a module, then it can be either in your kernel sources (you can try rebuilding the kernel or installing a new one then) or shipped as separate package.
  2. locate htc_9271.fw can help you determine, where the firmware is and if it belongs to the same package. If not, you should update this one as well.
share|improve this answer
That was never an issue before. If 0 updates happened between the time the computer was off and on, then the firmware shouldn't matter. And how would I upgrade the firmware? The Netgear software on Windows isn't running (process shows up, but nothing happens), and there isn't equivalent software for linux. – TheLQ Aug 7 '11 at 19:18
It is, possible that the firmware file got corrupted during emergency shutdown (for example). – rozcietrzewiacz Aug 7 '11 at 19:37
This seems to be an issue with Fedora's linux-firmware package. I did a complete reinstall on my desktop to 64bit (something I've been meaning to do). When excluding that package during the initial batch of updates and manually adding the firmware off of the wireless site ( wireless.kernel.org/download/htc_fw/1.3/htc_9271.fw ) it worked. Upgrading the linux-firmware package broke it. Seems that until they fix it, I need to manually update the firmware. Thanks a lot for the help – TheLQ Aug 8 '11 at 18:05

As rozcietrzewiacz stated, you have a firmware problem. What you must do is to update the relevant firmware by downloading it from here.

Then move it to /lib/firmware/ If it already exists, then replace it.

For more details you can visit the post of my blog.

share|improve this answer

When trying to search for a negative number using Google, put it in quotes e.g. "-22". Otherwise you are telling Google to reject search results that contain 22. There are many other people talking about error -22 when loading firmware into the ath9k.

share|improve this answer
I've fixed the problem already, but I'm pretty sure when I searched I did "-22" which includes the - sign – TheLQ Aug 17 '12 at 17:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.