Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install Scientific Linux 6.1 (which is literally RedHat Enterprise Linux without the branding) by booting its installer from my USB drive.

The installer starts fine, but two things happened:

  1. My USB drive appears as /dev/sda while my internal hard disk (the one I want to install the OS onto) is /dev/sdb. However, I would like my hard disk to be /dev/sda so that when I remove my USB drive after installation, my system can boot OK. How can I change this?
  2. Even though the installer starts, once I start the actual installation I get an error saying the installer can't find the "ISO 9001" install image.

Might these two issues be related? I would appreciate any suggestions... Thanks.

share|improve this question
2  
For the most part, it doesn't matter what letter the drive uses. There are just two places where the drive might appear; whether they actually do depend on your distribution. Do drive letters appear in /etc/fstab (the filesystem table)? Do they appear in /boot/grub/menu.lst or /boot/grub/device.map (the bootloader configuration — if Scientific Linux uses Grub 1, which I believe it does)? –  Gilles Aug 5 '11 at 21:53
1  
Yes, the big problem is grub. fstab uses UUID. If you complete the installation and grub doesn't boot, run the installer in "rescue mode" and execute grub-install /dev/sda. –  Juan Francisco Cantero Hurtado Aug 6 '11 at 8:17
    
I am currently experiencing this too (but with Oracle Linux). While I understand the sdX labelling is unreliable, unfortunately grub is treating the USB stick as (hd0,0) and the local disk as (hd1,0), meaning that when the machine reboots without the stick, it can't find the OS as at that point there is no (hd1,0). –  Burhan Ali Aug 6 '13 at 11:28

3 Answers 3

The devices listed under /dev/ are devices the Linux kernel finds and makes available to the system. You won't be able to change how this listing comes up without really hacking the kernel.

But there is good news, you don't have to. When you boot off of the USB stick, the kernel is running in RAM and enumerates the devices as it finds them. This is not a fixed mapping, meaning it will change with every boot if the devices are discovered in a different order. Basically what that means, is that after you install, if you remove the USB drive and restart, the main hard drive should come up as /dev/sda as it will be the first drive discovered. When you are installing, the Kernel is not the final Kernel image your system will be running, so you shouldn't worry too much about how the install kernel enumerates devices.

As for the second issue, it sounds like a corrupt image on the USB drive. You can try re-downloading and re-loading the image onto your USB drive and see if that helps fix that issue.

share|improve this answer
    
Thanks for the explanation. I am re-downloading the ISO to see if it helps, will report back. –  hpy Aug 6 '11 at 5:42
    
tried it with a newly downloaded image, didn't help... –  hpy Aug 6 '11 at 16:25

I just installed ClearOS (a CentOS derivative, which is also a RHEL clone) a few days ago onto a laptop that refused to boot from the CD. It was super lame, but I ended up booting from the USB stick like you did and then it read the actual RPMs from the CDROM because anaconda refused to use the USB image as the source. Anyway, I just confirmed that /etc/fstab uses the partition labels so no worries about the drives moving around.


Edit: I didn't mention, I used the Universal USB Installer to create the bootable USB stick. I used it fine for Fedora and CentOS in the past; for ClearOS I had to choose "other" with the "new" syslinux. If you are using another method to create the USB stick, you may want to give that a try. But it still didn't help me when it was trying to find the RPMs.

share|improve this answer
    
Labels or UUIDs are the resolution for this problem. –  Steve-o Aug 6 '11 at 3:35
    
That's what I said. My problem was that the laptop refused to boot from the CD-ROM, neither the internal nor an external USB one. –  Aaron D. Marasco Aug 6 '11 at 4:19
    
So did you figure out how to install from USB? –  hpy Aug 6 '11 at 5:43
    
Nope, sorry. It asked me if I was going to install from the CD or FTP. When I said CD, it said it couldn't find it until I put my burned CD into a drive. –  Aaron D. Marasco Aug 6 '11 at 11:58

Not sure about the second issue other than the already mentioned probable corrupted download.

As for the dev name, they are assigned on a first come, first serve basis, and the order of device detection is inherently unreliable. You can't control what device name a drive is assigned, and can not rely on it always being assigned the same one. You shouldn't have to worry about your internal hard drive being sdb. If that actually does cause problems, then file a bug report against the distribution because it is supposed to be able to handle that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.