Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Whenever I'm in vimdiff mode, my PuTTY session slows down considerably. This is especially noticeable when I try to scroll down many lines by keeping j pressed.

  1. Why is it so slow in comparison to regular Vim running under vsplit? I realize it matches across lines and color-highlights the differences, but does that account for all the speed differences?
  2. What can I do about it? I would like to keep line matches across files (and color highlighting as well). What settings can I change to help speed up the performance of my vimdiff utility?
share|improve this question
    
Simple, yet probably effective: page forward/back with ^F and ^B, respectively. Depending on your terminal mode, each jcan force an entire screen re-paint. –  msw Sep 9 '10 at 12:23
    
@msw : That's my current workaround, but it's still quite laggy in vimdiff mode. –  Zaid Sep 9 '10 at 12:52
    
How big are the files? –  Kevin M Sep 9 '10 at 16:33
    
@Kevin M : Not that big, 3000 lines max. –  Zaid Sep 9 '10 at 21:19
add comment

1 Answer 1

up vote 4 down vote accepted

Do you have SSH compression enabled? This kind of scrolling and highlighting generates a whole lot of redundant terminal traffic; compression makes a huge difference over a remote link.

share|improve this answer
    
It could very well be the reason. How do I disable/enable SSH compression? –  Zaid Oct 3 '10 at 15:28
    
PuTTY's SSH panel has a "Enable compression" checkbox. –  Piet Delport Oct 3 '10 at 18:00
    
Feels much faster after enabling compression... Thanks! –  Zaid Oct 5 '10 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.