Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an IBM blade server and we've installed RedHat Linux on the machine.

How can we check if we have both disks running as a mirror, or if everything is only running on a single disk? What commands can I use to discover this?

share|improve this question
add comment

3 Answers

Download the IBM management tools for your platform and install them, if you haven't already done so. You need to have the proper modules installed, in particular the RAID controller module. In the management tool, select Actions > System Status and Health > Physical Resources to see the attached disks.

If you have a support contract, this is exactly the kind of things that your support provider can walk you through.

share|improve this answer
add comment

There are several possible RAID configurations and it's not always obvious where to look.

If it is Linux software RAID, it will likely show up in the device name. If you run mount and look at the devices that you have mounted at various places, you will probably notice entries like /dev/sdaN. This is the standard representation for ATA hard disk devices these days. On the other hand if you see /dev/mdN, that is the conventional notation for software based RAID array devices under Linux.

If you are using hardware based RAID it's a little more complicated. Many of these devices will show up as if they were single drive devices. You should start with physically looking at the box to see if the drives are plugged into a RAID capable device. If so there might be indications from the POST messages during boot as well.

share|improve this answer
add comment

If you are using software raid in linux, look at mdadm --detail /dev/md0

If its hardware raid, you'll need to look in the bios / raid controller config during boot up to check what raid level it is using.

share|improve this answer
    
sorry but in my linux I not have the mdadm command - you have other command? –  david Aug 4 '11 at 13:10
2  
@david: That's one clue that you are probably NOT running software RAID! Like Sirex said your next step is to look at the hardware and boot time messages to see if some hardware device is setting up an array. –  Caleb Aug 4 '11 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.