Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In recent versions of popular Linux distributions (Ubuntu, Fedora, Mint, Debian) I always have to put acpi=off into the kernel parameter list before I want to boot the computer. This happens to both the live CDs and the installed version. I have been unable to find information on fixing this. I guess I have to change some settings in the kernel and compile my own (my Gentoo installation doesn't have this problem).

How should I go forward in fixing this ACPI thing?

Update 1: Screenshot enter image description here

Update 2: kernel config diffs (I grep'ed for ACPI so it's relatively short). If you want, also have a look at my Gentoo kernel config (working), and Mint's bundled kernel config (not working).

Update 3: I used the kernel config of Mint to compile a kernel for Gentoo and got the same error, which is a good sign that the problem is with the kernel config.

share|improve this question
    
What is the problem that you are getting when you don't set acpi=off? –  dirk Aug 4 '11 at 7:11
1  
Did you try comparing your working kernel config with the problematic ones - with sdiff for example? –  rozcietrzewiacz Aug 4 '11 at 7:14
    
@dirk: Not having acpi=off results in kernel panics when booting. The last line says something about "registering" and before that is a bunch of text that doesn't make sense to me. Will post the text when I get a chance. –  phunehehe Aug 4 '11 at 7:20
    
@rozcietrzewiacz: How do I get the config for the stock kernels of Ubuntu or Mint? –  phunehehe Aug 4 '11 at 7:21
1  
@phunehehe, in Ubuntu, you'll find the config in /boot/config-<kernelversion>. –  cjm Aug 4 '11 at 7:28

3 Answers 3

Generally this is caused by broken acpi bios, however, if you can identify a specific kernel version where it works without acpi=off, and one where it breaks, then you can start bisecting to narrow down exactly what change caused it. That could lead to finding a kernel bug that would need fixed, or possibly understanding the nature of the bug in your bios, and finding a work around.

share|improve this answer

Before you go into the hassle of custom-built kernel (which might do you good anyway), you can try some more boot options to either debug the problem or maybe even boot successfully. Here are some that I'd try: acpi=noirq, acpi=strict, pci=noacpi.

One simple trick you might use is to just run your Mint on the Gentoo kernel. To do that, you must copy files from two locations: /boot/ (where the kernel and initrd reside) and /lib/modules (where all the modules of each kernel are kept). The command uname -r, run from the working gentoo system, will indicate the appropriate files/directories you will have to copy to your Mint partition.

If you end up building your own kernel, mind two things:

  1. You cannot just use the kernel configuration from your working gentoo kernel with the sources from Mint (I'm referring to the configs you've pasted) - because they refer to different kernel sources. If you really want the gentoo configuration with Mint kernel, you can try to use the gentoo config file with the same or newer version of kernel sources from Mint. Then, you should copy the gentoo config tou your Mint sources directory, naming it .config and first of all run make oldconfig before doing any manual configuration.
  2. In case you might run into ACPI problems in the future, make sure to enable ACPI debugging (CONFIG_ACPI_DEBUG option) and read about using it in <your_sources_dir>/Documentation/kernel-parameters.txt and other files referenced from there.
share|improve this answer

I fixed it by adding the acpi_osi=Windows (lie) and acpi_backlight=vendor parameters as boot optional. The problem was due to a foxconn motherboard

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.