Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am seeing a horrible battery life with Fedora 15 (lovelock) with Gnome Shell 3 on my laptop. I keep the screen brightness, back light pretty low. I still get about 1 hr 50 minutes battery life out of it after a full charge while just browsing. I also got a brand new battery from lenovo but no luck.

I tried the workaround mentioned here — booting with pcie_aspm=force — but that did not help any.

It is a Lenovo T420s with a 6 cell battery. The kernel version is 2.6.40-4.fc15.x86_64 and CPU is Intel® Core™ i5-2540M CPU @ 2.60GHz. Kernel config can be found here.

Is this pretty much what everyone else is seeing? Is it something with Fedora 15? Should I downgrade to Fedora 14? Are there any specific packages I can remove to make the battery life better?

I think I should be able to get around 3 to 4 hours with a 6 cell battery - less than 2 hours sounds very low.

Here are paste bin links to power top wakeup stats and tunables stats.

FYI - I found this link to be an excellent source for tips on reducing power usage. I am going to follow some of the advices posted there.

share|improve this question
    
have u tried fallback? –  Tshepang Aug 2 '11 at 11:00
    
Please paste your kernel config on pastebin give the link. Your acpi configuration might be a problem. Dmesg would help also (output of dmesg command). –  rozcietrzewiacz Aug 2 '11 at 12:05
    
@Tshepang - By fallback do you mean to turn on the Forced Fallback mode? –  CoolBeans Aug 2 '11 at 13:39
    
@rozcietrzewiacz - ACPI kernel config here . –  CoolBeans Aug 2 '11 at 14:41
    
Oops, sorry I meant power management rather than basic ACPI settings. Can you post the whole config? Also, please write what CPU you are using. –  rozcietrzewiacz Aug 2 '11 at 14:51

6 Answers 6

up vote 4 down vote accepted

The program powertop should help you identify the problem.

   $ sudo yum -y install powertop
   $ sudo powertop

Look at the various output, and then arrow-key over to the rightmost "tab", Tunables. Look at the things which are "bad", and press enter to fix them.

Also, on the first Overview screen, look for any egregiously bad processes that might be causing wake-ups.

share|improve this answer
    
+1 Great tool. I got it installed and will try it out later. Thanks again! –  CoolBeans Aug 2 '11 at 18:36
    
Is turning on forced fallback mode supposed to help battery life? Just curious if it does. –  CoolBeans Aug 3 '11 at 1:08
    
Another question. I don't see "top causes for wakeups: listed under the overview table or any other tabs like it is shown here. Am I missing something? –  CoolBeans Aug 3 '11 at 4:16
    
I added paste bin links to my power top stats in the original post above. I am little confused on the wake up stats showing Audio codec hwC0D3 100% ... what does it mean? Also should I actually fix all the tunables there? Some of those are runtime devices? Wont that break stuff? Sorry for the ignorance on my part and many thanks for being so helpful! –  CoolBeans Aug 3 '11 at 4:47

Gnome-shell will not reduce your battery life to half. I think you have a CPU-intensive application running all time.

Charge your battery to full charge and restart the computer. Don't open nothing and review your battery life.

Charge again the battery to full charge. Open a terminal and run "top" in this. Open your browser and use normally. Check all your process in top and search the bad application.

share|improve this answer
    
Check also the answer of @mattdm. Powertop is very good for kernel internals. –  Juan Francisco Cantero Hurtado Aug 2 '11 at 17:10
    
+1 thanks for the suggestions Juan. –  CoolBeans Aug 3 '11 at 4:51

On the shell try

$ ps -A r

if you see some daemons running in an abnormal behavior kill it and restart the service if it is a needed service.

In the computer I observed that, I reinstalled the daemons (2) removing in full first. After that problem is gone.

share|improve this answer

On top of pcie_aspm=force, there are a small handful of extra parameters you can add that have a marginal impact on the power consumption of your Intel on-chip GPU.

i915.i915_enable_fbc=1 will enable frame-buffer compression, which wont directly reduce power consumption, but will reduce the memory bandwidth required to draw the screen - reducing the power usage of the chip by proxy.

i915.lvds_downclock=1 will reduce the LVDS refresh-rate. But as a consequence, may cause flickering on certain laptops that do not support it. The T420 supports this, so I assume the T420s will also.

drm.vblankoffdelay=1 will reduce wakeup events and provide another small gain.

Following this, there are more radical solutions like enabling Aggressive Link Power Management, which has the system place disks into low-power-mode when there isn't any activity. However, this can be dangerous, and I don't recommend trying it with your active installation.

And finally, there are good practices like disabling hardware you aren't using, setting a light background so less power is used by the screen, reducing necessary cycles by disabling sparsely used daemons, and using a lower brightness.

share|improve this answer
    
+1 good points. Thanks! –  CoolBeans Oct 13 '12 at 19:51

Use jupiterapp http://sourceforge.net/apps/mediawiki/jupiter/index.php?title=About and if you are using Ubuntu (it should support fedora too), check out the installation instructions at http://www.geeksailor.com/install-jupiter-nbuntu/

share|improve this answer

I've had this problem in the past (I think this has nothing to do with what DE/WM you're running on your machine) and an upgrade to the latest kernel (3.x+) solved it for me, now I can utilize my battery completely. It lasts me about 2.5 hrs

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.