Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install Virtualbox 4.1 from the .run file since Pacman had the 4.0 version only. But when I try installing the file using sh filelocation/filename.run, it gives me the following error-

Please install the build and header files for your current Linux kernel. The current kernel version is 2.6.38-ARCH

Is something broken in the kernel, or do I need to install something?

share|improve this question
add comment

2 Answers 2

up vote 5 down vote accepted

You need the "kernel26-headers" package installed so VirtualBox can compile it's accompanying modules

share|improve this answer
    
I installed it using pacman, but it still shows the error. It's written "Please install the build..." so do I also need to build it, or do I just need to reboot? –  Samrat Man Singh Jul 31 '11 at 13:44
    
Try running "/etc/rc.d/vboxdrv setup" to build the modules –  katriel Jul 31 '11 at 15:19
add comment

The current version in the repositories is 4.1.0-2.1: your mirrors are not up-to-date.

Choose a properly synched mirror, and pacman -Syy && pacman -Syu

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.