Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My local CUPS daemon on my laptop has an entry for a remote printer on my CUPS server. My local CUPS daemon thinks this printer is stopped, but it's not. The only interface CUPS gives me to manage this remote printer is a hyperlink to the CUPS printer on the server.

This tends to happen when something tries to query status on this remote printer when I'm not on my local network. The local CUPS will then permanently mark it stopped and say it couldn't find it.

However, once I get back on the local LAN it never removes the 'stopped' status. (Even rebooting does nothing)

The only way I can print again is to stop my local CUPS process, edit the /etc/cups/printers.conf file to manually change the status to "Idle", and restart the CUPS server.

Surely there's a better way??

EDIT:

Oh yeah, I previous solved this by creating a new remote printer entry. However, I couldn't find any way to DELETE the old remote printer entry. I had to edit printers.conf for that as well. Is there a way to manage remote printers entries at all?

EDIT:

This is CUPS 1.4.3. I also found a 'cupsenable' command that was only mentioned on the "What's new" page and the printers.conf docs online. I'll try that next time and see if it works.

share|improve this question
1  
I think CUPS has a default policy that says "stop printer on error". Here "printer" means the local software printer. I suggest you change it so that it doesn't. I've never understood the point of this setting. –  Faheem Mitha Jul 31 '11 at 6:26
    
@Faheem Mitha: Ah, that's interesting... I'll check that out. –  darron Jul 31 '11 at 21:11
    
@FaheemMitha its a very useful setting so that your jobs don't get lost because the printer went crazy... Not so useful for the printing single thing to printer sitting next to me workload, but essential for the "batch job fires off hundreds of jobs" workload or the departmental print server. –  derobert Jun 17 at 15:55

3 Answers 3

The CUPS CLI can do these things. Note that these commands aren't in the user path, only the root path. Depending on your CUPS config (is your user part of the CUPS SystemGroup?), you may or may not need to be root to use them. You can try from non-root by invoking via the full path (e.g., /usr/sbin/lpadmin).

You can re-enable the printer using

lpadmin -p «printer_name» -E

or

cupsaccept «printer_name»
cupsenable «printer_name»

(or, if you're wondering, disable it using cupsreject and/or cupsdisable).

You can delete even an auto-discovered network printer using:

lpadmin -x «printer_name»

I've tested disabling, enabling, setting and clearing reject, and deleting an auto-discovered network printer.

share|improve this answer

I have found out the hard way that sometimes to unwedge CUPS you have to restart it. Or even stop + start.

share|improve this answer

You should be able to access CUPS locally at http://localhost:631/. You can then resume the printer.

share|improve this answer
2  
Uh, no... that's the problem. I've been through what must be the entire local CUPS web interface. The only thing the web interface does is provide a link to the remote printer directly. The remote printer is fine, other computers can print. It's only my local CUPS daemon that thinks it's stopped. It's not a firewall issue or anything... as it'll work if I edit the printers.conf file directly. –  darron Jul 30 '11 at 23:01
1  
Hmm, that's odd. Mine lets me look at it in a local context as well as allows me to browse to the remote context. I am able to pause/resume locally. Sorry, I wish this had been more helpful. –  bahamat Jul 30 '11 at 23:06
    
I'm got CUPS version 1.4.3, what's yours? I noticed my web interface changed somewhat a few versions ago –  darron Jul 30 '11 at 23:13
    
@darron I have 1.5.0. –  bahamat Jul 30 '11 at 23:39
    
@darron: Click on printers and then select your printer. Go to the maintenance pulldown menu. There is an option to pause/resume the printer. I'm using 1.4.4 on Debian squeeze. –  Faheem Mitha Jul 31 '11 at 6:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.