Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a MythTV PV VM under Xen which I've spent about 2 weeks getting up and running. Everything seems to be working fine; PCI passthrough gives the card to the guest OS (OpenSUSE 11.4), the digital tuner works fine (I've successfully streamed Live HD TV to my PC), and I've very close to being very happy.

BUT, I cannot get LIRC configured for the life of me. I've spent the past 3 nights googling and reading tutorial and how to after another. I've found the firmware (HVR-1600 card), and got it loaded with the lirc_zilog module. It's recognized, and configured (by the Kernel/LIRC). I cannot, however, get it to do the following:

  1. I was able to capture IR signals from the stock Hauppauge Remote, but not the one from my DCT-700 STB (when I tried, I simply get a message that the gap length could not be determined, and no dots are shown).
  2. I have not been able to get it to transmit ANYTHING.

So, here's a quick example of some outputs:

dmesg output:

~ # dmesg | grep lirc
[   15.242456] lirc_dev: IR Remote Control driver registered, major 251 
[   15.277047] lirc_zilog: module is from the staging directory, the quality is unknown, you have been warned.
[   15.277882] lirc_zilog: Zilog/Hauppauge IR driver initializing
[   15.282904] lirc_zilog: chip found with RX and TX
[   15.283556] i2c i2c-0: lirc_dev: driver lirc_zilog registered at minor = 0
[   15.338267] lirc_zilog: Zilog/Hauppauge IR blaster firmware version 2.1.0 loaded
[   15.339013] lirc_zilog: chip found with RX and TX
[   15.339638] i2c i2c-0: lirc_dev: driver lirc_zilog registered at minor = 1
[   15.369278] lirc_zilog: Zilog/Hauppauge IR blaster firmware version 2.1.0 loaded
[   15.369296] lirc_zilog: initialization complete

An irsend test:

~ # irsend --device=/var/run/lirc/lircd SEND_ONCE dct700 OK
irsend: command failed: SEND_ONCE dct700 OK
irsend: transmission failed

The corresponding /var/log/messages

~ # tail /var/log/messages
Jul 29 10:16:36 lal lircd-0.8.7[1090]: accepted new client on /var/run/lirc/lircd
Jul 29 10:16:36 lal lircd-0.8.7[1090]: write failed
Jul 29 10:16:36 lal lircd-0.8.7[1090]: Protocol error
Jul 29 10:16:36 lal lircd-0.8.7[1090]: error processing command: SEND_ONCE dct700 OK
Jul 29 10:16:36 lal lircd-0.8.7[1090]: transmission failed
Jul 29 10:16:36 lal kernel: [  227.063942] lirc_zilog: failed to get data for code 0, key 9050 -- check lircd.conf entries
Jul 29 10:16:36 lal lircd-0.8.7[1090]: removed client

Relevant portion of /etc/lirc/hardware.conf:

#Chosen IR Transmitter
TRANSMITTER="HVR 1600"
TRANSMITTER_MODULES="lirc_zilog"
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE="/dev/lirc0"
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF="/etc/lirc/lircd.conf"
TRANSMITTER_LIRCD_ARGS=""

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="true"

I'm quite sure the dct700.conf file is wrong. I copied it from a forum of someone who claimed to have this STB working, but it's for a USB MCE transmitter.

Since I cannot get the receiver to record the signal from the remote, I cannot generate my own.

SO, if anyone has a similar combination working, or knows someone who does, or sees something wrong and has a suggestion, I would be eternally grateful for any help.

share|improve this question
add comment

1 Answer

I got this working a short time ago, Mark's Braindump came back online, and following his directions to load the firmware, as well as tips & configuration files for the codes and transmitter have resolved the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.